WLAN connects from desktop browser but not from Android

If I have the rpi connected via ethernet it is visible to Android.
If I have the rpi connected via [dhcp or static] wifi it is not visible to Android. It still responds to Linux desktop browser and MSWindows desktop browser in wifi mode.
I have the rpi on a static ip on the wlan, yet it won’t respond to ping nor tracert, nor wireshark can see it.
There’s obviously traffic to the desktop browser but watching a new track load whilst using wireshark I do not see the destination ip.
I have a pihole doing dns and dhcp.
I have set a static reservation in pihole for the volumio rpi.
It responds to the desktop browser using its ip address.
I have UPNP renderer turned on
I have Sharepoint-Sync turned on
I have DLNA browser turned on
I tried to discover it using BubbleUPNP on Android phone. No response.
In Android, using a firefox based or chrome browser it does not respond to the IP address, nor hostname
The Android browser message is: “This site can’t be reached”
I have tried bonjour browser on Android but that doesn’t find it either.

I have obviously overlooked something simple and I would appreciate your feedback in helping me troubleshoot this.