Wireless netwrking broken on Pi 1 (ver. 2.246)

I can’t get wireless networking on version 2.246. I’ve tried several pi’s and usb network adapters but nothing works. On first boot the hotspot works a bit but becomes flakey if I try and turn on wireless networking. I can see my local networks id’s but when I connect to them nothing happens. I’ve tried wired connection and configuring from that, or connecting to the hotspot and then configuring a wireless network but nothing works.

I tried turning off hotspot, (as I don’t need/want it) to see if that helped but when hotspot is turned off I am unable to turn wireless networking on. Hotspot has to be turned on, for me to enable wireless networking.

Everything works great with a wired connection, but nothing I try seems to get wireless to work. The fact that the adapters can see the networks, and the fact I’ve tried several wireless networks, with excellent signal strength makes me think this is more of a software issue.

I saw some old conversations about wireless issues but these seemed to be related to power saving mode on the Edimax adapaters. I have tried that adapter, but several others as well, all with the same result.

Any help greatly appreciated. I’m going round in circles here.


Have you tried to change the channel in volumio WiFi settings?

Yep, I tried that but it made no difference. The hotspot was pretty stable until I tried to enable wireless networking. Then neither worked. Only way I’ve been able to use them was to use a wired connection.

I’m just burning a couple more SD cards so I’ll test that again now.


I’ve got an image that works now. Exactly that same image as before, and the same 3 or 4 pi’s and network adapters I tried several times with before. But I’ve now got one that works, so I configured it and cloned that one. The only thing I can think is that I did the start up process in a different order. Hotspot didn’t work on the one I got to work. I used a wired connection, even though the hotspot didn’t seem to be working, I changed the channel, connected to my wireless network then, removed the wired network cable and rebooted. This time it connected to the wifi when it came back up.

So all working now. Thanks for the channel selection tip, I’m not sure if it was that (as the hotspot didn’t work) or just that I did something in a different order this time but I got it working. And very nice it is too. It’s a couple of years since I last used Volumio and it’s looking really nice now. The youTube plug-in is great and the GPIO plugin as great potential. I’m impressed that the multi-room picked up straight away. It would be really cool if you could sync different rooms (or is there a way and I’ve missed it?).


Have a look at the beta Snapcast plugin from Saiyato