Wireless Adapter Compatibility List

Adapter Name:TP-LINK Archer T1U AC450
Driver/Firmware: dl.dropboxusercontent.com/u/802 … 748.tar.gz
Working with Volumio: Yes 1.55
Tested Versions and Platforms: RPi2 & PiDAC+ (iqaudio)
Buying Link: amazon.co.uk/gp/product/B0159ED6L6

howto intsall
connect putty to ssh IP wired connction
login: root password: volumio

wget https://dl.dropboxusercontent.com/u/80256631/mt7610-3.18.5-v7-748.tar.gz tar xzf mt7610-3.18.5-v7-748.tar.gz ./install.sh

connect wireless:) via web interface

works ok with mp3 not with flac files
prefer to use wired connection

Official dongle does not work in 1.55 out of the box, but can be made to work.
shop.pimoroni.com/products/offi … ifi-dongle
Official Raspverry Pi Wifi dongle is based on BCM43143 chipset.

Thanks @ Jerry

the following steps worked for me.
step 1 was about 40MB so make take a little time to download.

THE below URL gets trunkated and you can’t copy and paste it so I’ve split the single command accross two lines breaking at the P char
sudo git clone --depth 1 git.kernel.org/p <----
—> ub/scm/linux/kernel/git/firmware/linux-firmware.git

full link is:
git://git.kernel.org/pub/scm/linux/kern … rmware.git

cd linux-firmware
cd ./brcm (only copy these firmwares)
sudo cp -R * /lib/firmware

remove the dongle.
Plug it back in after 10 seconds and you shoudl now see a device recognised as a network but it didn’t work until after a reboot for me.

TP-LINK TL-WDN4200 N900 Wireless Dual Band USB Adapter
worked out of the box on 1.55 on a 2.4 Ghz wifi with WPA2

Adapter Name: Cisco Linksys AE3000
Chipset: RT3573
Driver/Firmware: wikidevi.com/files/Ralink/dr … x_1005.zip
Working with Volumio: NO
Tested Versions and Platforms: Volumio 1.5
Comments: Didn’t succeed in compiling the driver mentioned above (see here)
Buying Link:

1 Like

Adapter Name: unbranded
Chipset: unknown
Driver/Firmware: unknown
Working with Volumio: NO
Tested Versions and Platforms: Volumio 1.5
Comments: works on Raspberry Pi 2, with OpenElec / Kodi, but not with Volumio.
Buying Link: aforyou.nl/wifi-adapter-usb-802.11-n

(VERSION: 0.976 - when did 2 turn into 0.X ???)

Official Raspberry Pi dongle working after installing extra drivers.
See previous update.

To get this working in the above version my previous instructions in this thread didn’t work.
Instead I copied the entire of the git cloned firmware folder into /lib/firmware/ and rebooted.

This fixed it. not idea, but quicker than looking for the specific driver.

Sorry I have a Digicom Wave 54, i found this link:
blogs.dotnethell.it/imaginsystem … 19397.aspx

My set-up:
Raspberry Pi 2
amazon.it/Raspberry-Pi-Mode … berry+pi+2

VERSION: 2.041
RELEASE DATE: 12-12-2016

problem with this zd1211-firmware
any idea to solve?


Adapter Name: TP-LINK Archer T2U AC600
Chipset: N/A
Driver/Firmware: 11/21/2013,
Working with Volumio: 2.118
Tested Versions and Platforms: Raspberry Pi 3, HiFiBerry DAC+ Pro
Comments: worked out of the box, no extra drivers needed. Did not work with USB-Data-Stick beside, took cable to put adapter to position with best connection. Then worked with USB-Data-Stick. Tested with Web Radio, Spotify and Spotify Connect, NAS (flac).
Buying Link: https://www.amazon.de/TP-Link-Archer-T2U-Adapter-AC-Speed/dp/B00K11UIV4/ref=sr_1_1?s=computers&ie=UTF8&qid=1490187644&sr=1-1&keywords=TP-Link+Archer+T2U+AC600 (TP-LINK: http://www.tp-link.de/products/details/Archer-T2U.html)

Adapter Name: ANEWISH Wifi Dongle AC Dual Band
Chipset: RTL8811AU
Driver/Firmware: bit.ly/2irNQhA (not needed with newer versions)
Working with Volumio: Yes
Tested Versions and Platforms: Volumio 2.141
Comments: Works out of the box on 2.141 (presumably driver has made it into the mainline kernel), however previous versions required modules compiled
Buying Link: amazon.co.uk/gp/product/B01G77I46G

Intermittent functionality upon reboot on 2.175, using USB hub works around the issue. Many messages similar to “Transfer to device 5 endpoint 0x1 frame 825 failed - FIQ reported NYET. Data may have been lost”. Couldn’t be bothered to debug further - fairly obviously an upstream issue.

Csl wlan 300 wifi dongle:

This cheap wifi dongle (about 10€) is working good in my audio system (Volumio 2.185 - rpi3 - Kali - Piano 2.1) without problems.
Works good with big DSD128 files…
is not enough for DSD256, I experienced stuttering audio…

Can you find the chipset (eg. from lsusb) please, so I can add it to list? I did Google it, but there seems to be more than one chipset in use. Cheers :slight_smile:

Same problems with my pc desktop… ill try again this evening… sorry…


Mi chiamo Paolo.

Vi chiedo gentilmente di aiutarmi nell’installazione dell’interfaccia usb Edimax EW-7811UN per connettere via Wi-Fi volumio 2 montato su raspberry-B. Scrivo in italiano perché il mio inglese non è ottimo.
Ho provato a seguire le istruzioni dei forum ma senza esito.
Una volta configurato l’apparato e salvata la configurazione il dispositivo non si allaccia alla rete wifi. Non sto usando pwd, ed ho dato un indirizzo statico alla connessione wired che invece funziona perfettamente.
Devo fare qualcosa in particolare?

La risposta puo’ essere in inglese.

Grazie fin da ora .


Good morning.

My name is Paolo.

I kindly ask you to help me install the usa Edimax EW-7811UN usb interface to connect via Wi-Fi volume 2 mounted on raspberry-B. I translated from Italian with an automatic translator because my English is not great.
I tried to follow the forum instructions but without success.
Once the device is configured and the configuration is saved the device does not connect to the wifi network. I’m not using pwd, and I gave a static address to the wired connection that works perfectly.
Do I have to do something in particular?

Thank you for now.


Adapter Name: Compex WLE200NX
Chipset: Atheros AR9280
Driver/Firmware: bundled with volumio
Working with Volumio: YES, out of the box.
Tested Versions and Platforms: some 2.x up to at least “volumio-2.201-2017-06-14-x86.img”
Comments: mini-PCIe adapter, supports 802.11A/B/G/N 300Mbps
Buying Link:

Adapter Name: Tinxi 665040000
Chipset: RTL8811AU
Driver/Firmware: ?
Working with Volumio: No
Tested Versions and Platforms: Volumio 2.201
Comments: 802.11AC 1T1R, max 433Mbps on 5ghz, 150Mbps on 2,4ghz, hotspot mode supported.
Buying Link: /

[spoiler]Download and install the new version of the script with commands

sudo wget http://www.fars-robotics.net/install-wifi -O /usr/bin/install-wifi sudo chmod +x /usr/bin/install-wifi
To install the driver on your current kernel you should just need to run command

sudo install-wifi

This will select the driver you need and automatically download and install it.

All credit for the script goes to MrEngman on Raspberry Pi forum.[/spoiler]

Dongles for latest Volumio version running latest Kernel? Trying to find a dongle that works with Digi+ Pro/Latest Volumio

An old one, now, but very stable.

Adapter Name: MSI US54SEII
Chipset: Ralink RT2501/RT2573
Working with Volumio: Yes, no additional driver necessary
Tested Versions and Platforms: v2.201 & v2.254 x86
Comments: Good range, 54Mbps max on 802.11g, Hotspot mode supported
Buying Link: Second hand ?

Would you so kind as to advise E-Ink Tablet for control Volumio installed on Sparky SBC? Thank you in advance!

i appreciate you are trying to find an answer to your E-Ink question, but would you please please open your own thread and not post in threads that have no relation to your question.
Thank you.