Windows folder share


I have read few threads and still having issues of adding a windows folder as a library.

I have setup a folder which is accessible as \\music\ (no password needed since I added Group/Username everyone)

Tested with another PC, all working.

In Volumio, Add library, as follows;

Source Name : media
fileshare protocol : SMB/CIFS
ip address:
Remote directory: music

And when I save mount options,

Last system mount error
mount error(127): Key has expired Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

  • Please help

I too am having issues with this on Volumio 2

Would be keen to hear of someone who has it working

I’m not sure why its so hard to add a window share folder to Volumio,
bit frustrated and helpless.

I even created a windows account, use that credential to login, got permission error that time but no luck.

Look like I have to give up this product. :cry:

Why give up so quickly?

I can tell you that this is almost certainly a config issue on your Windows machine. The error would imply that the password you are using has expired or is incorrect.

I can see that you haven’t specified one, so have you disabled password protected sharing on the windows machine? … s-7-a.html

By default Windows will only allow windows machines in the same HomeGroup to see shares as a guest. Linux or another OS would need to provide credentials.

Also, you say you have added ‘Everyone’ to the share permissions, but what about the file permissions? The two are separate and without permissions to both it will not work.

AlphaPapa, its frustrating because I have tried few combinations of things for hours and still no go.

I try to use ‘Everyone’, ‘Guest’ to folder permission in windows, and try to connect with no username and password, no luck but it says expired error.

Then I created a user account in windows, add that to the folder permission, use it’s credentials to login, then I’m getting permission error.

Is it possible to add the folder through back-end? any instruction on that?

I doubt that this is a volumio or a UI issue, I have volumio connecting to a windows server 2012 share that has Everyone set as read with no problems at all.

Have you turned off password protected sharing like i mentioned? Are you able to access these shares from another machine?

I have had fits with this in the past and every time it turned out to be my error. Make sure that you are using the right path and that all /s and \s are proper - even try without it.

It is a great program and we’ll worth figuring this out.

Lastly there is a way to mount a drive in Linux but that is a bit over my head - I never needed it because I finally got it right.

Oh and once you get it right - take a photo of it and even back up the SD card.