Wifi issues on Zero W - Configure wifi manually?

Is there any way to configure the wifi connection manually? Can it be done like in Raspbian, where simply adding the wpa_supplicant.conf in the boot partition enables the wifi?
I’m bringing an installed Volumio to a friend and I want to pre-configure the Wifi, since I had some issues with it.

Background:
It’s an R-Pi Zero W with Volumio 2.502. When installing at his place, each time we configured the wifi connection via the hotspot, the hotspot would disappear but the Pi did not connect to the network. The hotspot did not reappear as supposed to after several reboots and the only option was a factory reset and try again. Signal strength was fine at 70-90% according to my phone.
After several failed attempts I took his Pi home and established that this happened in my network too, with two different SD cards and two R-Pi Zero W’s (both Volumio 2.502). The Pi simply did not connect to my network, nor enabled its hotspot for configuration.

I did notice something strange in the setup (via Volumio app on Android): I would select network X, enter the password and confirm, and it would show ‘Network Y configured’. After that, it was unreachable. It seems that the wizard wrongly configured the network, and that the hotspot does not start when the network is present but authentication fails.

If needed, I have a spare Zero W to test some things with (if I can find a keyboard…).

Idem here with version 2.513

Well, I’ve just tried it too with a RPi0 W and v2.513. All worked fine.

Not sure that Raspbian’s wpa_supplicant.conf in /boot will work, but manually altering /etc/wpa_supplicant/wpa_supplicant.conf should do so (don’t alter any other networking files). Stick to the following format for wpa_supplicant.conf

ctrl_interface=/var/run/wpa_supplicant network={ scan_ssid=1 ssid="my_ssid" psk="my_password" priority=1 }

Try v2.513 first though before fiddling round with ssh and manually altering wpa_supplicant.conf

1 Like

Thanks for the reply, chsims1.
I did update to 2.513 now, but for my friend’s Pi I’ll just set it manually via SSH. I don’t want to risk that it does not properly work there and I have to reset several times again. Too bad this file can only be altered when the system is running, would be a lot easier otherwise.

I’ll try it again with 2.513 on my own Zero W.

Hmm, once the installation has been properly set up, you should be able to edit wpa_supplicant.conf directly on the sd card (in a reader).

Interesting, I couldn’t find the file on the sd card directly (nor the /etc/network folder to edit the interfaces).
I added the network via SSH now. Wifi still works here, hopefully it will connect at his place immediately too.

In the meantime I’ll install 2.513 on my spare Zero W and see what happens if the authentication fails.

Confirmed: if the network is available but authentication fails, Volumio fails to start the hotspot.
After manually editing the wpa_supplicant on the sd card, it connects to the wifi again just fine.

Thank you, I have this problem, try to enter password many times each time I have to start from the beginning now it run with Windows 10, I don’t know if i can use an ipad to run volumio or i have restart everything
Thank a lot