WiFi Issue: RPi 3 w/ DAC+ Pro w/ Volumio 1.55


FYI: I am new to RPi and have put together a RPi 3 with DAC+ Pro (with HiFiBerry plastic case) with Volumio 1.55 (from HiFiberry Installer) only. Pretty much a plain vanilla set up for DAC+ Pro connected to my NAS. In general, it works as expected but I run into the following issues with respect to the on-board WiFi:

Issue #1: I couldn’t get the on-board WiFi to connect (similar to someone above). Rebooted, tried different wifi network on different routers, etc., nothing seemed to work and kept getting the “No Wireless Interface Present” status. So, I’ve continued to use the Ethernet, but would like to get WiFi to work without a dongle.

Issue #2: After about 3 failed attempts of setting WiFi (in #1), Volumio starts acting weird … volume pointed to zero but the actual output is 100% and volume dial became non-responsive and not adjustable. I wiped the SD and reload Volumio to start over. Every time I tried to set up WiFi for about 3 times, the same volume issue came out again, and sometimes playlist would even become non-responsive. And I had to reload the SD image again.

Any insights would be appreciated.



An additional issue to report as bug:

Similar to issue #2 above, every time I change any parameters in the Playback, i.e., changes to MPD within Volumio, volume control points to zero and not adjustable. But the actual output is at 100%.

Same problem here, using a Mac, on new RPi3 with hifiberry DAC. The instructions on volumio.org/get-started don’t work, including using the sudo dd command line method, but the hifiberry installer does but then Wifi doesn’t work.

/etc/network/interfaces is set up ok: It was set up by the net-config.php form. But there is no wireless IP from the RPi in the router.

auto lo
iface lo inet loopback

auto wlan0
iface wlan0 inet dhcp
wireless-power off
wpa-ssid ABCAK15EAC6
wpa-psk 3T38754T96542

auto eth0
iface eth0 inet dhcp

i can confirm the same issue. rpi 3 in this case without external dac, but installer for volumio from hifiberry used. wifi does not work.

lsmod shows the brcmfsmac driver which should be the right one, but ifconfig does not show wlan0. my /etc/network/interfaces looks the same as bethnal’s. ifup wlan0 fails.

I finally got the WIFI to work on my Pi 2 and Volumio, thought to myself “great”… Turned off my Pi turned back on and discovered that I have no WIFI again… Damn… Now I am going to try Rune Audio…

Sent from my SM-G900W8 using Tapatalk

Guys, 1.55 hasn’t been touched in a long time. So it won’t work with some DACs and boards.

We’re working on Volumio 2 that is a complete ground up rewrite that you might have more luck with. github.com/volumio/Volumio2

We are putting the final things into place to release a new RC2 version very soon that is an even bigger step on from RC1.

It’s not volumio bug, but hifiberry. Check this tread github.com/raspberrypi/linux/issues/1588
This also applies to newer versions volumo and runeAudo, moods and Max2Play.
Only when I set fixed channel 5, WiFi in raspberry 3 works fine.

Wysłane z mojego ONE A2003 przy użyciu Tapatalka

I can confirm this post. I’ve had similar issues which in retrospect were also WiFi issues. (see: 029-crash-when-playing-file-with-khz-samplerate-t5183.html#p24319)

Thanks ernol007 for pointing out the post to github. This solved my issues as well!

Volumio 1.55 is unsupported for a while now (of course community contributions are still welcome)
So why not try Volumio 2 on a spare SD?

Eh. I use volumio 2. It is to affected with this bug - it is hardware error

Wysłane z mojego ONE A2003 przy użyciu Tapatalka