WiFi issue--Can SSH in but Client cannot connect

I was hoping to get WiFi working with my Realtek RTL8192CU dongle…A couple issues:

  1. It doesn’t work at all when I have it plugged into a USB hub. I’m using a 2amp power supply so was hoping that power would not be a problem.

  2. If I plug the WiFi dongle directly in to the RPi I can SSH in, and Ping works, but the client (eg GMPC) can’t connect to the server. (In that configuation the DAC and the data stick with the music on it is not plugged in…does that matter?)

Thanks for any help and suggestions (Note…I’m a noob, particularly with linux).


Use your ssh to modify the mpd.conf file. Change the listening address from to “any”. That worked for me. If I lose connection now I restart mpd over the ssh connection (sometimes I have to do it a couple of times.
Hope this helps.

Thanks, Ian. Turns out it was a combination of the USB hub I was using…and stupidity on my part. Once I figured out what a dumb thing I had done, changing to a different USB hub solved the problem.

But I do lose connection sometime and so will try restarting mpd as you suggest.