Wifi is ageing me horribly

Hi guys. I give up, and bow to your wider knowledge.

I’ve had my Rpi running volumio for a week or two now, connected via ethernet and to my NAD receiver by the 3.5mm jack (booo! lol)

My problem is that before I can implement a few more around the house, I need to get the Wifi working.
I have a WiPi (Ralink?) USB dongle that works perfectly with full Raspbian and XBMC/Kodi, but I cannot for the life of me get it to work with my new toy.
I’ve followed several guides online to setting up Wifi using this specific dongle, but none of the “Solved” threads get me working.
from the command line I have updated the system, installed wicd-curses, tried at least a dozen different configurations in /etc/network/interfaces but to no avail. I’ve even flashed a second SD card to see if that helped.

What I have noticed is that If I boot the Pi with both ethernet and the Wipi connected, and scan the network with Fing, I see both “devices” breifly, before the wireless disappears, followed shortly by the ethernet, forcing me to power-cycle the Pi - not ideal, I know.
I’ve had a monitor connected to watch progress and on occasions with both connected, the Pi gets itself into a boot loop, constantly restarting every three of four seconds. With other configurations it appears to boot, but continues to pipe masses of entries onto the screen, over the volumio logo and command line.

I hope I’m missing something simple, but there’s my problem!