wifi & date/clock

The volumio + raspberry2 work very fine on my sabre dac, but…

  1. My wifi dongle realtek rtl8188cus won’t link with my internet box. The dogle is wifi n and normally abble to link my intenet box (livebox 1 wifi b/g only)
    Eth0 works fine, I can ssh pi@volumio.
    What can I do?
  2. what’s the way to update the date/time at the boot.
    Perhaps silly questions but hard for a newbie on linux
    So long

I installed Volumio last night and also had problems with wifi. Solved it using instructions in the following link: raspyfi.com/wi-fi-on-raspber … ple-guide/

There are several ideas on how to go about it. I choose to follow these instructions:

ssh in and do:
sudo nano /etc/network/interfaces

Change it to this:

auto lo
iface lo inet loopback

#Remove the wired network because it
#slows down boot if it’s not connected.
#auto eth0
#iface eth0 inet dhcp

allow-hotplug wlan0
auto wlan0
iface wlan0 inet static
address #(IP address you want to assign to your Volumio)
gateway #(IP of router in your network)
wpa-ssid MyWirelessNetwork
wpa-psk MyPassword

Worked perfect for me. The obvious problem with this solution is that the unit will be tied to your home setup and the file needs to be manually changed if you move your unit to a different network.

Regarding date/time: run “raspi-config” at the command prompt and set the correct time zone

Thanks a lot for the quick answer.
I have done all the sudos for wlan and volumio run perfectly with a wifi master mode N.
But when i try to connect to my internet box (orange livebox1) which is only mode B/G, impossible to connect!
On google lot of people are saying that dongle wifi N can connect wifi B/G without problems.
I don’t understand what happens

For the DATE/TIME the volumio boot write: fake hw… clock, writing system date time, or something like that, and thre date is on december 2013 etc…
I look for modify the boot script to have actual date and time

I think the problem with the date is that the time zone may be way off, it was for me. You can fix the timezone by change the following, I’m in CST so change your path accordingly:

sudo rm /etc/localtime
sudo ln -s /usr/share/zoneinfo/US/Central /etc/localtime