Why Volumio cannot handle reboot even after all these years?

Thank you for you reply.
I have Pi3B with the PI2Media 502DAC hat, connected through the AES/SPDIF output to the Hegel H80 amp. The wireless network is disabled, I’m using the wired connection to connect to audio files on the local network.
At first, I had one more Pi3B board connected through the USB port to the amp (comparing sound quality between two), I had it running only for few weeks but the same happened at least ones.


It just happened to me. I had a power outage with Volumio running. And now it won’t boot up! I used to turn it off every night and never had a problem booting back up for about a month, until now. Is there anyway I can save it? Or I’ll have to begin again?

Yes, original issue was resolved.

The solution was this (what I wrote on Apr '18):

" So I did some further digging and we might be dealing with Windows 10 anomaly (READ: “Feature” of windows 10) instead of problem with Volumio. When writing to sdcard with Win32DiskImager with windows 10, and further verifying it, immediately throws verify error. This is issue that apparently does not have solution in windows 10. See this post."

After that I had zero problems; Volumio image has been working perfectly for 2 years. I’m using volumio 2.5.13 and dared not to update it ever since.

Still, I am baffled how my OSMC has been the same SD image for past ~4 years with dozens of updates and resets/power shortages and I never had a single boot problem with it. Even though I used same win32diskimage writing method than with volumio.

1 Like

Thanks! Well, it did boot up in the end after about 10 minutes. And I just restarted it, and it’s been working fine so far.

I don’t use Windows, Mac OS here and using Etcher to flash the card, so I don’t think it’s the same issue.
Maybe when it doesn’t boot correctly it’s trying to fix itself, like checking integrity, etc…

Thanks again

Hi Pablo_Villegas,
Do you run Pi3? I added Pi4, now I run Pi4 USB to the Amp’s USB input, and Pi3B with the PI2Media 502DAC hat to the amp’s SPDIF input. It happened to Pi3 few times since I have two Pi setups. One time the card was damaged (I’m thrugh few SD cards with this setup). It still hasn’t happen to Pi4. I don’t use W10 to format SD cards, tried with W7 and Linux, same results.

I only have Pi4, and it has only happened once, it was bottling up and the power went down, so, after that it took about 10 minutes to boot up. But it did. And it’s been fine after that.

Hi, I’m a newbie into RBP world and just built one as Spotify Streamer.
I’m on RBP 4 and volumio loaded into SD card.
Need help with this sometimes ok sometimes not scenario that I’m going through.

  1. what is the proper shutdown procedure? Do I go to System menu and select Shutdown. Wait for red light to go off and proceed to power down RBP?

  2. what else can I try in getting this to be more stable? I could only do power on and off cycle and hope it works.

I’ve image the latest volumio and both Spotify plugins added. Nothing else done.

Thanks in advance.

Quick update:

On laptop web browser, all is working well.
On phone browser, the main page is still not loading. Also, Spotify device list is not showing up.

Now I’m really baffled…

Your phone must be connected on your local network via WiFi to be able to see Volumio and Spotify connect. Check it.

It seems this still isn’t fixed. I’m on 2.907 and Raspberry Pi 3 B+ and I’ve had this issue with every version of Volumio I’ve used.

what is the problem that you have @jmath ?

Volumio randomly won’t boot up sometimes, just as described in this thread.

i just try again most of the time it runs the second time.

1 Like

Volumio can’t restart properly still in 2022 on Volumio 3.

It’s a annoying. Im using RPi 4 2gb.

Sorry but, with all my devices (and plenty of others) that’s not the case.
Can you explain in more details what happens? What kind of devices do you have connected to your PI?

1 Like

Aha, I have none devices connected, only PNY 128gb SD card with Volumio. After pressing restart its usually doesn’t boot up.
Need to turn off and on dc several Times…

What kind of power supply you have?

I have this issue from time to time in my car.(pi is powered by phone charger in there), while the one i have at home with proper power supply never have this issue.

Not original, its 5v 3.1a extreme something.
Maybe its a problem?

do you see any boot or just hangs at the begining?

win32diskimager burn it with this and see what it does.