Why does volumio can´t play m4b files?

Hallo community,

my stored library is appr. 3.900 albums - mostly mp3 encoded but all my audiobooks (lots of them for my kids) are all m4b encoded. Volumio is unable to play these m4b-files! Or to be more precise: volumio recognize the files with all their information in tags and plays them well - but with no sound! Not a single tone! Total silence!

Does anybody know why? And much more important: what´s the solution?


Black Senator

1 Like

m4b appears to be a dedicated file format:

“M4B audio files are nearly identical to M4A files. They are usually encoded with the AAC codec. M4A files contain audio books and the file format supports chapters and bookmarking. These files is supported by iTunes or VLC.”

I think you should look for a “m4b” to “mp3” converter.

I haven’t dealt with the problem for a long time - also because my Logitech Media Server or iTunes played the m4b file without complaint. The current corona crisis has exacerbated the problem - but now I also had time to deal with it.
First, I installed an instance of moOde* to test whether this alternative player can handle this files. But the player also remains silent. So back to volumio. The only solution is to convert all m4b files back to mp3 (thousands! - no fun).

Nevertheless I would be interested to know why volumio cannot play the files - but other players can! In fact, I previously converted the mp3 to AAC using iTunes and renamed the m4a files to m4b. What I hadn’t tried is the possibility whether there are converters that convert mp3 directly (natively) to m4b and whether volumio can handle it.


Black Senator

  • P.S. I was curious to see what impression moOde made on me. Especially when open source projects are increasingly commercialized - like at volumio, I become critical and like to look for more independent alternatives. However, I have to say that moOde - even if it is now available as a finished distribution - is far from the usability that volumio offers. Starting with the language of the user interface, menu navigation, settings, plug-ins(?) and so on

the version of mpd used in volumio is supposed to read m4b files. You can check using “mpd -V” in a console.
The “no sound” your are facing may be due to the output format, incompatible with your DAC. Have you tried to enable resampling in Volumio?
If noy better, try to to use a plugin such as equalizer, as the output is resampled.
let us know :wink:
if you have a sample of a file that cause problem, it could be useful to help

edit : I tested with a free file and it works with no problem. So, I really suspect and sample problem with your dac