Weird noises with Allo USBridge Signature

Hi guys. Newbie here. Please be gentle.

Apologies if this has been covered before.

I’ve just bought an Allo USBridge Signature and I’ve been experiencing weird noises when using Volumio with it. The noises are a bit like a CD skipping but just in the high frequencies. I initially thought it might be a buffering problem so I’ve changed the buffer to 12mb and buffer before play to 40% but still the issue persists.

I’m using the USBridge with a 1GB/s ethernet connection straight into my router with the files residing on a Synology NAS. My DAC is an Arcam irDAC and nearly all my files are ALAC M4A’s.

The issue seems to be more pronounced with certain recording but effects both 24bit and 16bit files the same.

Curiously, if I play the same files over AirPlay they sound perfect. Which leads me to think that Volumio is the culprit rather than the files or the USBridge. The same files also play back perfectly played directly from iTunes via USB to my Quad Vena2.

Any thoughts? It’s driving me nuts.

USBBridge (being based on CM3, Raspberry PI Compute module 3) plays crackles when playing hi resolution audio, for the known issue of PI with USB on high res audio. (reason is some packageare dropped instead of being trasmitted via USB).

Unless a special driver is installed, USBBridge will then exhibit those problems in Volumio.

Allo never provided a device to us nor never tried to integrate this driver in Volumio, so this is why you’re having the issue with USBBridge and Volumio. Also, since this question pops up pretty frequently, I guess they don’t even warn their customers about this issue…

1 Like

Thanks for the speedy response.

Oh. That’s disappointing to hear. TBH their site is pretty light on information.

Is there anything that can be done about this or is it just a fundamental flaw? I take it that the issue would be present if I tried a different OS?

The unit is pretty useless as is.

1 Like

Have a look at this post

mind that if you do it, you might break OTA updates…

Cheers for that.

First impression is that it seems to have fixed the issue. I’ll report back once I’ve had a proper listen.

Really appreciate your help. :slight_smile:

I’ve had chance to have a proper listen to a variety of bit depths… and the issue is totally cured.

Thanks again for your help. Hopefully it hasn’t broken OTA updates, but time will tell.


Hm I was to believe that the USBridge was just a device to power your PI and to isolate its USB port the right way. Now it seems Allo uses special software?
I’m not so happy to hear this, especially since it seems that Allo is not eager to corporate with Volumio.
I will make my complaint at Allo.
For now I have to see how this SSH stuff works…

Hi all,

With some help of my neighbour I managed to get it all to work again.
We had to perform a factory reset
sudo echo > /boot/factory_reset

Which brought me back to version 2.699. This does give problems again but after updating the ethernet driver all works effortless with Hi-Res content as it did before.

I will think twice the next time before I press update…

Just a quick update to let you know that OTA updates still work after manually updating the driver.

Hi all,

Does anyone has experience with the latest updates (2.907) in relation to the USBridge Sig?
Will this still cause the same troubles as before or has this been fixed between Allo and Volumio?



Hi Jordo.

Since I updated the driver (as detailed above) I’ve not had a problem with my USBridge Signature and OTA updates still function correctly. I’m currently running v2.907.

I’ve no idea if Allo are still shipping units without the correct driver but it’s pretty easy to fix if needed.

It’s a great little streamer for the money.


1 Like

Hi Commotion,

Thank you for your reply!
Good to hear. As I can remember it didn’t worked out for me with the version at that time and I had to degrade to 2.699 again. I see it worked at once for you without stepping back in version.

Have Allo and Volumio found a collaboration yet? Does anyone know?

No worries Jordo.

TBH I can’t remember which version I started with but other than updating the driver it’s worked flawlessly since.

I hope you can find a way to make it work for you.


Yesterday I decided to update to the latest Volumio version.
It seems to work fine even with the higher bitrates.



Awesome. Glad it’s working for you. Good work. :slight_smile: