webinterface not working / volume not linear

Hi guys, im am using a Raspberry Pi B+ running Volumio 1.55 and have encountered some problems.

The webinterface (and Volumio Andriod App) is not showing everything it should and does not allow to control anything.
This is how it looks:

If I enter the webinterface via typing “volumio” into the browser these problems do not occur, if i start to play some music and go to the webinterface via ip-adress the music continues playing but ist shows what is seen in the picture above. As soon as i try to change anything nothing works and the music stops playing. As it works fine when accessing the webinterface via volumio (volumio.local does not work strangely) it is not that big of a problem, but the same problem occurs on the volumio app.
When this problem occured for the first time I tried rebooting and ended up formatting the sd card and starting over, but after some time it started to cause problems again.

Another problem is that the volume control works in a strange way, I know there is a common issue, but I´m not sure that it is the same as mine:
The volume is not linear, if I set volumio to 40 alsamixer shows 9 … 60 results in 20; 80 in 44; 90 in 67; so it is tricky to set the correct volume.
Is that the common issue or is there a way to change this?

The only changes I made after downloading the image were:
raspi config keyboard layout, forcing sound via 3,5mm output and installing exfat to be able to use the usb-stick and I tried to update via webinterface.


i am a brand new user of both volumio and rpi and I am having a similar problem, with the same set up.

Leon, when you say “If I enter the webinterface via typing “volumio” into the browser…”, what do you mean? i used the web interface (on my old toshiba laptop, running chrome) and typed “volumio.local/index.php” in the address bar. i was able to control the player fine the first time i did this. i then downloaded the app for android (i have a samsung galaxy s tablet), but had to enter the ip address of the rpi. this app worked the first time i used it.

a little while later the app stopped working and when i tried to connect to the rpi via volumio on my laptop, it said it was “connecting”, but never did. by the way, the music kept playing all through this, so i guess that’s something.

any help would be greatly appreciated.

You should probably reboot your pi, that should solve it for now. If the connecting screen comes back I’ve seen a fix for it a while ago. This was done by changing a line in the Web page’s code

Volumio 1.5 and rpi b+

I rebooted the pi yesterday and i was able to connect to it with my laptop, but when i clicked the “playlist” tab, nothing showed … which was odd becauaei had added music to it andwas listening to that music.

I hate to say it, but i am an old dog and new tricks like “changing a line in the Web page’s code” might be beyond my abilities.

As a curious addendum, my son’s old -school ipod touch was able to stream and control his music to the rpi via its internal music player from an entirely different floor of our house! Does Volumio “get along better” with Apple products than Android or PC?

Any thoughts or advice will be greatly appreciated.

You added the tracks after the reboot? The playlist isn’t saved between boots.

Apples airplay has a good implementation but dlna also works.

You added the tracks after the reboot? The playlist isn’t saved between boots.

Apples airplay has a good implementation but dlna also works.
Yes. The tracks that i added after the reboot did not show in the playlist, but i could hear them playing. Is there something i need to change in the volumio settings in order for the tracks to show in the playlist. The music files are on a usb drive, plugged directly into the rpi. Thanks.