Web UI seems to block some devices

I am experiencing a weird problem. Here’s the typical scenario:

  1. Throughout all of this the Volumio server is up and running, continuously playing a web radio station, so it has Internet connectivity.
  2. I use the Volumio web UI (volumio/ is not responding. No matter what I do (try IP address in browser, change browser app, clear cookies etc.) I can’t access the UI with A.
  3. However, if I switch to a another client (device B), the UI works. I then check A and it still can’t access the UI…
  4. After 1 hour or so, device A is working again and can access the UI!

As I have no other networking problems, I think this has to do with the Volumio web server. Could it be that it’s actively blocking clients?

Any ideas?

There shouldn’t be any blocking, can you still ping volumio when you loose connection?

Can you still ssh it? Is there any chance another device is configured with the same IP?

The device, is it a phone or a laptop?

Thanks for your suggestions. The device varies, sometimes it’s an iPhone, sometimes an iPad.

I will check SSH connectivity. I assume that it will work given that the Volumio DNS name works on other devices.

I agree it sounds like some sort of IP conflict. The fact that the blocked device regains access reminds me of how DHCP servers work, releasing IPs after a while. Right now I can’t see how any IP conflicts can arise in my DHCP home network but I will look into it.

During my tests today only one of my clients, an iPad, was blocked from Volumio’s web UI. All other devices worked and SSH worked too. Illustration of my setup:

Volumio setup.gif

Some more info:

  • While blocked from Volumio, the iPad could access all other websites
  • Using the IP of the Volumio server (instead of volumio) didn’t help
  • The iPad ( doesn’t seem to have an IP conflict with another device.
  • The Volumio initial response time varied across the client devices, on one it was > 10 seconds
  • The blocked iPad was unblocked once I restarted it.

I don’t know if this is a Volumio issue or a problem with something else. But I’ll keep investigating and am thankful for any ideas you might come up with.

Just a idea : have you changed the player name ?

I haven’t changed the player name, so the default name volumio remains in use.

After upgrading an iPhone to iOS10 yesterday it too began experiencing initial Volumio web server response times in excess of 10 seconds. This is strange, as Volumio web UI works snappily on other devices in the same network.

When a device doesn’t work, can you try to ping the volumio IP, ping your non working device from volumio.

Best would be to use ARPING as it provides any mac address linked to the IP. ARPING needs to be installed and run with SUDO

I got more info now. My iPads were working, but suddenly an iPhone was blocked from Volumio. I immediately started investigating the problem:

  • When pinging the iPhone from the Volumio server, it responded
  • When pinging the Volumio server from a working iPad, it responded
  • When pinging the Volumio server from the iPhone, it didn’t respond

So the problem goes deeper than the web server. The whole Volumio server seems inaccessible to the device that gets blocked. This seems like a server-side problem to me.

20 minutes later the blocked iPhone magically regained access to Volumio. Pinging Volumio from the iPhone then worked.

I would rather think that this issue could be related to your router… Does the blocked device have access to internet?

The blocked device has access to Internet, it is only Volumio that gets blocked. Not the same device gets blocked; sometimes it’s an iPhone sometimes an iPad.

Could be router-related, but I think the odds are against it: I have never experienced any other similar trouble with my router. My ISP upgrades and manages it remotely. AFAIK it is a “vanilla setup”.

Do you have any idea how I could try to test the router-error hypothesis, perhaps using some networking tools?

If Volumio can still ping the phone, there is probably no issue with the router.

Somehow, packets going to volumio from the device are discard somewhere. First thing coming to my mind is : do these device have all a sim card? This is possible that cellular data + wireless is activated and creates this issue.

Next move would be to run TCPDUMP on volumio to see what’s going on .

Another test would be to ping other devices from the device in trouble, just to see if it gets isolated from LAN communication or just to Volumio

Frustrated, after not being able to find any cause for this behavior, I threw out some of my networking hardware (including a WiFi extender) and installed a new router. That solved the problem :smiley:. Although I still don’t understand how the problem could manifest itself the way it did, my hardware was apparently broken or set up improperly.

Thanks to everybody who tried to help out. I learned a lot from this experience.