Web Radio issues with RPI HiFi AMP HAT TAS5713

I recently bought a RPI HiFi AMP HAT TAS5713 (https://www.amazon.com/dp/B07CZZ95B9?psc=1&ref=ppx_yo2_dt_b_product_details) from Amazon and got everything work.

I have encountered and issue and was wondering if anyone might be able to shed some insight to what might be happening. When I used the headphone jack on my Raspberry Pi 3 I was able to get all of my local radio stations from the Web Radio. However when I moved to the RPI HiFi Hat suddenly some stations don’t come in. All I get is some static. I reverted back to the headphone jack on the Pi and those channels worked again. Moved back to the AMP hat and the issue came back. I tried using the streaming links and add those as custom favorites but that still didn’t help at all.

Just seeing if anyone else has ran into this issue before or maybe can shed some light to what’s happening.


Hi Tomas, welcome to Volumio. :slight_smile:

Do you see similar issues with local audio files? What i2s DAC have you selected in the Volumio UI? Try the HiFiBerry Amp.

Local music doesn’t appear to have this problem. I currently have the HiFiBerryAmp selected and I tried both that one and the HiFiBerry Amp2 and the issue persisted on both selections.