Web admin don´t work after installing squeezelite plugin

I try to set up Volumio on my setup with Pi 3B, IQaudio DAC+, 7" touch RPi as a standalone player.

But after installing the Squeezelite plugin and rotating the display 180 degrees and rebooting, the player is no longer available via the web interface. I have tried both via wifi and LAN. I can connect via ssh, is there something I can do to restore the web interface?

Thanks in advance
Trond Kjetil

what is this Jivelite plugin ?

A “squeezebox” skin. I use Logitech Media Server (LMS, aka Slimserver and Squeezeboxserver) and want to set up the player as a Squeezebox alternative

so, this is not a plugin for volumio… check messages with journalctl -f but hard to help you…

Sorry, I should have written “Squeezelite”, I have edited the post

Are you still able to reach Volumio’s webinterface from another device (PC, smartphone…)?

Edit: I missed

so I assume that’s not possible.

As balbuze already mentioned, the logs could possibly help to spot the reason. Please execute sudo journalctl -f --no-tail and post the result.

I tried that, but got no results from it. Now I have burned the microSD with a clean image, and try to install the 7" touch display plugin only.

Could be the fastest way :wink:

Now I can access Volumio via the web interface, and with the 7" touch screen and Squeezeplayer plugin installed. But I don’t find the Logitech Media Server (standalone) from Volumio, and the LMS don’t see the Volumio player.


Sorry, I can’t help in that regard - I have no experience with LMS and squeezelite plugin.

To bad. After a restart the web interface won’t work any longer. Guess Volumio is for me. I give it up.

Does this happen only with the squeezelite plugin installed?

It does, yes. But as long as I cannot get a connection to my LMS server, Volumio is useless to me.

IIRC @Saiyato has developed the squeezelite plugin. Maybe PM him if he is able to help.

Hi @trondkj,

Can you share what you did exactly during install and what your intended outcome is?

I want a pi with LMS and Squeezelite with jivelite screen (touch).

I installed Volumio 2.xxx, plugins:

  • LMS
  • Squeezelite
    and I installed Jivelite with this script: /link/to/script (or the script contents)

The ‘official’ plugins work in conjunction with one another, but your setup contains something else, which breaks the WUI.

Hi Saiyato

I installed Volumio 2.806.

Then I installed the 7" touch display plugin. Reboot worked ok. Could still access web admin panel. Second the Squeezelite plugin. Third: Installed Audiophonics power button plugin.
Then tried to get a connection with my Logitech Media Server, on another RPi, but did not succeed. Tried to install LMS plugin on Volumio. Did not help. Did a reboot, and after that: no web access.

What I want to have a pi with Squeezelite as a standalone music player that works with my 7" touch screen, be it Jivelite or something else that works.

It works with PiCoreAudio and Max2Play, but I wanted to give Volumio a try.

Hi @trondkj,

I just fired up a Pi 2B (and a Boss DAC) with Volumio 2.806. I installed the following plugins (in order)

  • Cisco DUO (for SSH security)
  • Spotify (misclicked)
  • Touch Display (even though I have no screen attached)
  • Squeezelite player
  • Audiophonics on/off
    All worked fine, then I rebooted and everything still worked fine. The player is auto-advertised to my LMS instance running on Windows Server. I’m now installing LMS on the Pi itself.

Can you elaborate more on how you tried to connect with LMS on the other Pi? Is everything running on the same network segment without any IPS/firewall snooping packets?

For your info, LMS exposes ports 9000 (TCP), 9090 (TCP) and 3483 (TCP & UDP), this should not interfere with the WUI (TCP port 80).

As Squeezelite was installed and running I expected the player to appear on my LMS web page, but it did not. I tried to connect from the Volumio web management tool, but didn’t make it. Now I’ll have to reburn the image on the micro SD, not sure when or if I will do.

Of course I have both server and player on the same network.

Hi @trondkj,

Maybe you needed to restart Squeezelite once for advertising to work properly. Not sure, didn’t pay too much attention after first install. I could select it from the drop-down (right under my Duet).


My plugin settings:

Another option is to manually hard-connect the client to the LMS by adding the CLI commands: -s {server-ip}:9000

i have a similar setup.
I installed volumio and squeezelite plugin on a raspberry pi 3b, and installed picoreplayer/LMS on another raspberry pi 4b with a 3.5 inch touchscreen and it works as a sever.

for me it all works perfectly.