Waveshare amoled 5.5 touchscreen plugin doesnt work after update

I used since at least one year a combination of volumio 2.xx + touchscreen plugin + Waveshare 5.5 Amoled. And yesterday I updated to latest Volumio 2.9x + latest plugin 1.3.3

Every time I’m trying to run the plugin a get an error: “Touchscreen - error connecting X server”

I have no idea hot to fix it…
Any help if you please?

Is this a fresh Volumio installation?

Positive, fresh install - new SD card, the newest image, the plugin has been installed from WebUI but I tried to install it by SSH and doesnt matter which way I do it - always I get this error message.

I check the log “/home/volumio/.local/share/xorg/Xorg.0.log” for errors:

[ 238.576] (EE) systemd-logind: failed to get session: PID 2499 does not belong to any known session
Fatal server error:
[ 238.595] (EE) parse_vt_settings: Cannot open /dev/tty0 (Permission denied)
[ 238.595] (EE) Server terminated with error (1). Closing log file.

Did you wait several minutes after the first boot of Volumio?

If not you could try

touch /boot/resize-volumio-datapart

and reboot.

After the data partition has been fully expanded you would also have to uninstall and re-install the Touch Display plugin.

I did (I think so)
Anyway done again: uninstall / datapart / reboot / install
Still get x server connection error.
I stuck :pensive:

Please post the result of

cat /var/log/Xorg.0.log


chromium-browser -version

volumio@volumio:~$ chromium-browser -version
/usr/bin/chromium-browser: line 138: lsb_release: command not found
/usr/bin/chromium-browser: line 139: lsb_release: command not found
Chromium 56.0.2924.84 Built on Ubuntu 14.04, running on

volumio@volumio:~$ cat /var/log/Xorg.0.log
cat: /var/log/Xorg.0.log: No such file or directory

volumio@volumio:/var/log$ systemctl status volumio-kiosk
● volumio-kiosk.service - Volumio Kiosk
Loaded: loaded (/lib/systemd/system/volumio-kiosk.service; disabled)
Active: failed (Result: exit-code) since Fri 2021-10-22 14:01:16 UTC; 8min ago
Process: 9604 ExecStart=/usr/bin/startx /etc/X11/Xsession /opt/volumiokiosk.sh – -nocursor (code=exited, status=1/FAILURE)
Main PID: 9604 (code=exited, status=1/FAILURE)

Oct 22 14:01:01 volumio startx[9604]: at http://wiki.x.org
Oct 22 14:01:01 volumio startx[9604]: for help.
Oct 22 14:01:01 volumio startx[9604]: (EE) Please also check the log file at "/home/volumio/.local/share/xo…tion.
Oct 22 14:01:01 volumio startx[9604]: (EE)
Oct 22 14:01:01 volumio startx[9604]: (EE) Server terminated with error (1). Closing log file.
Oct 22 14:01:16 volumio startx[9604]: xinit: giving up
Oct 22 14:01:16 volumio startx[9604]: xinit: unable to connect to X server: Cannot assign requested address
Oct 22 14:01:16 volumio startx[9604]: xinit: server error
Oct 22 14:01:16 volumio systemd[1]: volumio-kiosk.service: main process exited, code=exited, status=1/FAILURE
Oct 22 14:01:16 volumio systemd[1]: Unit volumio-kiosk.service entered failed state.
Hint: Some lines were ellipsized, use -l to show in full.

volumio@volumio:~/.local/share/xorg$ cat Xorg.0.log
[ 1534.449]
X.Org X Server 1.18.4
Release Date: 2016-07-19
[ 1534.450] X Protocol Version 11, Revision 0
[ 1534.450] Build Operating System: Linux 4.4.26-v7+ armv7l Raspbian
[ 1534.450] Current Operating System: Linux volumio 4.19.118-v7+ #1311 SMP Mon Apr 27 14:21:24 BST 2020 armv7l
[ 1534.450] Kernel command line: coherent_pool=1M 8250.nr_uarts=0 cma=256M video=HDMI-A-1:1080x1920M@60 vc_mem.me_base=0x3ec00000 vc_mem.mem_size=0x40000000 splash quiet plymouth.ignore-serial-consoles dwc_otg.fiq_enable=1 dwcotg.fiq_fsm_enable=1 dwc_otg.fiq_fsm_mask=0xF dwc_otg.nak_holdoff=1 console=ttyS0,115200 kgdboc=ttyS0,115200 consoe=tty1 imgpart=/dev/mmcblk0p2 imgfile=/volumio_current.sqsh elevator=noop rootwait bootdelay=5 logo.nologo vt.globl_cursor_default=0 loglevel=0 snd-bcm2835.enable_compat_alsa=1 snd_bcm2835.enable_headphones=1
[ 1534.450] Build Date: 11 November 2016 11:59:59AM
[ 1534.450] xorg-server 2:1.18.4-2+rpi1 (Debian -- Support)
[ 1534.450] Current version of pixman: 0.32.6
[ 1534.450] Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
[ 1534.450] Markers: (–) probed, () from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[ 1534.451] (==) Log file: “/home/volumio/.local/share/xorg/Xorg.0.log”, Time: Fri Oct 22 14:01:01 2021
[ 1534.475] (==) Using config directory: “/etc/X11/xorg.conf.d”
[ 1534.475] (==) Using system config directory “/usr/share/X11/xorg.conf.d”
[ 1534.479] (==) No Layout section. Using the first Screen section.
[ 1534.479] (==) No screen section available. Using defaults.
[ 1534.479] (
) |–>Screen “Default Screen Section” (0)
[ 1534.479] () | |–>Monitor “”
[ 1534.485] (==) No device specified for screen “Default Screen Section”.
Using the first device section listed.
[ 1534.485] (
) | |–>Device “Allwinner A10/A13 FBDEV”
[ 1534.485] (==) No monitor specified for screen “Default Screen Section”.
Using a default monitor configuration.
[ 1534.485] (==) Automatically adding devices
[ 1534.485] (==) Automatically enabling devices
[ 1534.485] (==) Automatically adding GPU devices
[ 1534.493] (==) Max clients allowed: 256, resource mask: 0x1fffff
[ 1534.493] (WW) The directory “/usr/share/fonts/X11/cyrillic” does not exist.
[ 1534.493] Entry deleted from font path.
[ 1534.493] (==) FontPath set to:
[ 1534.493] (==) ModulePath set to “/usr/lib/xorg/modules”
[ 1534.493] (II) The server relies on udev to provide the list of input devices.
If no devices become available, reconfigure udev or disable AutoAddDevices.
[ 1534.493] (II) Loader magic: 0x6d5f20
[ 1534.493] (II) Module ABI versions:
[ 1534.493] X.Org ANSI C Emulation: 0.4
[ 1534.493] X.Org Video Driver: 20.0
[ 1534.494] X.Org XInput driver : 22.1
[ 1534.494] X.Org Server Extension : 9.0
[ 1534.528] (EE) systemd-logind: failed to get session: PID 9626 does not belong to any known session
[ 1534.529] (II) xfree86: Adding drm device (/dev/dri/card0)
[ 1534.532] (II) no primary bus or device found
[ 1534.532] falling back to /sys/devices/platform/soc/soc:gpu/drm/card0
[ 1534.536] (II) LoadModule: “glx”
[ 1534.542] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[ 1534.595] (II) Module glx: vendor=“X.Org Foundation”
[ 1534.595] compiled for 1.18.4, module version = 1.0.0
[ 1534.595] ABI class: X.Org Server Extension, version 9.0
[ 1534.595] (==) AIGLX enabled
[ 1534.595] (II) LoadModule: “fbturbo”
[ 1534.595] (II) Loading /usr/lib/xorg/modules/drivers/fbturbo_drv.so
[ 1534.600] (II) Module fbturbo: vendor=“X.Org Foundation”
[ 1534.600] compiled for 1.18.4, module version = 0.5.1
[ 1534.600] Module class: X.Org Video Driver
[ 1534.600] ABI class: X.Org Video Driver, version 20.0
[ 1534.600] (II) FBTURBO: driver for framebuffer: fbturbo
[ 1534.601] (EE)
Fatal server error:
[ 1534.603] (EE) parse_vt_settings: Cannot open /dev/tty0 (Permission denied)
[ 1534.604] (EE)
[ 1534.605] (EE)
Please consult the The X.Org Foundation support for help.
[ 1534.607] (EE) Please also check the log file at “/home/volumio/.local/share/xorg/Xorg.0.log” for additional inormation.
[ 1534.607] (EE)
[ 1534.608] (WW) xf86CloseConsole: KDSETMODE failed: Bad file descriptor
[ 1534.608] (WW) xf86CloseConsole: VT_GETMODE failed: Bad file descriptor
[ 1534.608] (EE) Server terminated with error (1). Closing log file.

Thanks for the log. Short of time right now. Will come back to you soon.

Apart from the Touch Display plugin did you install other software? If so, which?

Not at all. RPi is like a virgin, image volumio-2.917-2021-10-06-pi and 1.3.0 plugin from WEBUI, only. Before I’ve asked for - I have used search engine, really. I didnt find anything related to my case.


To check free disk space you may run

df -h

and post the result.


strange… missing partition? where is it?

Looks ok.

Did you change the user name or did you try to install the plugin manually as root?

Additionally please post the output of

ls -al ~


  1. I didnt change the user name
  2. I didnt try to install plugin manually as root

Ok, let’s a have a look at “/etc/X11/xorg.conf.d” and “/usr/share/X11/xorg.conf.d” then with

ls -al /etc/X11/xorg.conf.d
ls -al /usr/share/X11/xorg.conf.d

Also please post the output of

ls -al /tmp/.X11-unix

1 Like

Please check if xserver-xorg-legacy is installed:

apt list --installed | grep xserver-xorg-legacy

volumio@volumio:/$ apt list --installed | grep xserver-xorg-legacy
WARNING: apt does not have a stable CLI interface yet. Use with caution in scripts.
xserver-xorg-legacy/oldstable,now 2:1.18.4-2+rpi1 armhf [installed]

I got to go - as the player is in my office :wink: But will come back on Monday!
Just to let you know: it’s a vintage TEAC mini system with Dynaudio speakers.
Cassette Deck on the top has been DIY modified to Rpi Volumio. All physical buttons used as well as rotary knob (as an encoder)
Some pics

Thank you in advance for your support. I need to fix it.

1 Like

Ok, I have no access to a Volumio 2.917 system ATM, but will check at the weekend.

One thing I just spotted in the Xorg.0.log:

There appears to be a an error in “/boot/cmdline.txt”. I have “highlighted” the part “consoe=tty1”. This should read “console=tty1”.

You can edit the file using nano

sudo nano /boot/cmdline.txt

To save the file and close the editor hit Ctrl+x, y and Enter. Then reboot.

seems to be correct in a file. Most propably something happens when copy/paste