Waveshare 7.9inch HDMI LCD install?

  1. Connect the display to HDMI0 of the Pi 4.

  2. Install the Touch Display plugin.

  3. Connect to Volumio via SSH.

  4. Open “/boot/userconfig.txt”

nano /boot/userconfig.txt

and add the following lines

hdmi_group=2
hdmi_mode=87
hdmi_timings=400 0 100 10 140 1280 10 20 20 2 0 0 0 60 0 43000000 3
hdmi_blanking=1

Save the file by hitting Ctrl+x, y and Enter.

  1. Reboot.

Thank you, I will try…


whats next

Assuming you want the display to show Volumio’s UI in landscape mode: On the Touch Display plugin’s config page under “Orientation Settings” set rotation to 90 or 270 degrees and reboot.

1 Like

please rotate the screen with the settings from the wiki. I had some issues with the touch rotation when rotating it by the plugin. The screen rotated perfectly but the touch orientation was 180 degrees of. needed the unadvised hardware button to get the touch orientation correct.

@Wheaten Has this been with version 3.3.5 of the Touch Display plugin?

euh… well it was about 7 months ago…
But seeing youjr response, that part has been resolved :slight_smile:

@Wheaten Yes, version 3.3.1 of the Touch Display plugin had a problem applying touch rotation settings. But that should be solved in 3.3.5.

@cocoda At first please try if the rotation setting on the Touch Display plugin’s config page. If that should not work it would early enough to modify files manually. :wink:

Hi
with the following Code in /boot/config.txt
it will function :grin:

initramfs volumio.initrd
gpu_mem=32
max_usb_current=1
dtparam=audio=on
audio_pwm_mode=2
dtparam=i2c_arm=on
disable_splash=1
hdmi_force_hotplug=1
force_eeprom_read=0
hdmi_group=2
hdmi_mode=87
hdmi_timings=400 0 100 10 140 1280 10 20 20 2 0 0 0 60 0 43000000 3
hdmi_blanking=1
display_rotate=3

Thank you a lot
in the Futere it will become a case!

This is just wide and high enough to house the screen:

1 Like

:+1:

Did you try out setting the rotation option of the Touch Display plugin to 270 deg. instead of putting

display_rotate=3

into “/boot/config.txt” and with what result?

I recommend to put these lines

hdmi_group=2
hdmi_mode=87
hdmi_timings=400 0 100 10 140 1280 10 20 20 2 0 0 0 60 0 43000000 3
hdmi_blanking=1

into “/boot/userconfig.txt” instead of “/boot/config.txt” otherwise they will not survive the next Volumio update. :wink: The same goes for display_rotate=3 if you don’t achieve the same result using the plugin’s option.

1 Like

@cocoda Did / do you have the chance to check if using the rotation option of the Touch Display plugin instead of manually setting display_rotate=3 works with your display?

I have to test it but now I have a other problem:

What can I do?

That would be nice :slight_smile:

You mean the audio?

Yes

I don’t use spotify connect and can’t help in that regard, but you may have a look at these threads:

If your issue should not already be covered there, I suggest to open a new thread to get attention for the sound problem.

are you using an external dac or just the 3.5 audio output from the raspberry pi itself or HDMI?
if you are using an i2s dac you could change under playback options/mixer type to software/hardware or try none.
you could also try setting/changing audio resampling.
do a reboot after making any changes.

could also be a 5 volt power problem from the raspberry pi or external dac that is poorly powered.

I use a external USB Dac. If I use the audio of the pi is it all fine

you could change (if the option is present) under playback options/mixer type to software/hardware or try none and check if the problem goes away.
do a reboot after each adjustment.

Hi
I run volumio on a raspberry 4 which has two HDMI ports.
Is it possible to use the ultra wide-screen for PeppyMeter and the other Display (TV) to show volumio normally?