Waveshare 5.5 Amoled

Hello,
has anyone ever applied given config.txt lines and made it work? I guess I am running in some Xserver issued or there is general incompatibility with touch plugin.
Waveshared assumed Raspian and gave following lines
max_framebuffer_height=1920
max_usb_current=1
config_hdmi_boost=10
hdmi_group=2
hdmi_force_hotplug=1
hdmi_mode=87
hdmi_timings=1080 1 26 4 50 1920 1 8 2 6 0 0 0 60 0 135580000 3
dtoverlay=vc4-fkms-v3d
display_rotate=1

For some reason I see “Volumio” also rotated, then comes TTY login and that’s it although WebUI works fine.

Some help would be great.
Best
J.

What is the exact model name of the screen?

Did you install other software related to the screen than the touch display plugin? If so what software is it?

Did you enable the touch display plugin?

You might also try removing

from config.txt.

Thank you for first ideas. In fact I tried a number of combinations. I think I have a rather naked volumio latest. I only have this touch plug-in running, also deactivated it once. No success. Since latest update I sometimes get the noisy screen. Before I simply had the little writing “Login . . .” Turning image actually works. Only one step I did which potentially has influence: I loaded the xscreensaver which seemed to plough into volumio raspian. If updating removes these action I can’t say.
Best J.

That could well be the culprit. Updating Volumio would not remove xscreensaver. You might try to remove it executing sudo apt-get -y purge --auto-remove xscreensaver (and then maybe reinstall the touch display plugin).

Or you start with a fresh Volumio image and only install the touch display plugin as a start. I would recommend to add the display specific settings

max_framebuffer_height=1920
config_hdmi_boost=10
hdmi_group=2
hdmi_mode=87
hdmi_timings=1080 1 26 4 50 1920 1 8 2 6 0 0 0 60 0 135580000 3

to /boot/userconfig.txt instead of /boot/config.txt.

This has the advantage that these entries remain untouched when Volumio gets updated. In contrast /boot/config.txt gets overwritten on each Volumio update (further information) and you would have to edit it again.

Since max_usb_current=1 and hdmi_force_hotplug=1 are already part of the “standard” /boot/config.txt there is no need to add them to /boot/userconfig.txt.

Good evening, very kind and a precise action plan. I will try and follow up what happened.

Well, this worked out. Super! Now I need to adjust scale of representation. Letter and icon size does not work for normal usage. Super tiny. Could happen I have to adjust to half resolution or other raspian settings allow me to enlarge font size and general representation. But: So far many thanks. A new image did it! Here we are 11pm. So good time whereever you are and good look with comerade C19. Cheers.

Good luck of course . . . :wink:

:grin: Regarding the UI: If you should currently use the “contemporary” theme you could try the “classic” theme and check if this fits better. You can switch between the themes in the appearance settings.

P.S. If applicable mark the thread as solved so other users with an issue can identify threads containing a solution to a problem more easily.

I was already checking both, tend to use classic anyway, but my initial mistake could be choosing a 1920*1080 on 5.5". After some research I found that I potentially have to command chromium to scale. Simply addressing screen with some other 16:9 resolution would sacrifice the sharpness I guess. I will report.

Sorry for my unawareness. Touch plug-in is basically your work. Maybe I can add some experience here: With this waveshare screen the screensaver never comes, although it is recommended to use one.
You can put whatever time, tell him to use also during playback. Screen is on. :sweat_smile:
I have no progress about text scaling. I will look what chromium can do.

Could you please post the result of xset -display :0 q when the screensaver timeout has been set to 0 and also when the timeout has been set to 10 seconds?

What you could do, too, is watching the log with sudo journalctl -f at the moment where you save the screensaver setting from the plugin’s configuration page and also when the screensaver should shut off the screen. Please post the result here or (maybe better to not clutter this thread) PM it to me.

Edit: If possible test the screensaver function using another HDMI monitor to rule out an issue with your touchscreen.

You can try the --force-device-scale-factor flag. It requires editing /opt/volumiokiosk.sh. You can open this file with sudo nano /opt/volumiokiosk.sh. Then search for the section starting with while true; do and add e.g. --force-device-scale-factor=1.5 \ so it looks like this:

 while true; do
  /usr/bin/chromium-browser \
    --force-device-scale-factor=1.5 \
    --simulate-outdated-no-au='Tue, 31 Dec 2099 23:59:59 GMT' \
    --disable-pinch \
    --kiosk \
    --no-first-run \
    --noerrdialogs \
    --disable-3d-apis \
    --disable-breakpad \
    --disable-crash-reporter \
    --disable-infobars \
    --disable-session-crashed-bubble \
    --disable-translate \
    --user-data-dir='/data/volumiokiosk'     http://localhost:3000
done

To save the changes hot “Ctrl+x”, “y” and “Enter”. After that disable and enable the touch display plugin.

Another method to scale chromium is to connect a keyboard to your RPi and use “Ctrl”+"-" respectively “Ctrl”+"+". Note that you need to use the “-” or “+” keys from the number block.

P.S. What is your Raspberry Pi model?

  1. Uuh, I was searching for the forced scaling factor. Thank you for hint. I worked fine but apart from plugin restart a system restart was needed to scale and reorientate the touch as well.

  2. My pi is a 3B, combined with allo piano 2.1 and allo volt. Pre-owner left me an RASP EXPLORE 500 installed first in the stack which I did not utilze so far.

  3. If set to 0 sec:
    volumio@volumio:~$ xset -display :0 q
    Keyboard Control:
    auto repeat: on key click percent: 0 LED mask: 00000000
    XKB indicators:
    00: Caps Lock: off 01: Num Lock: off 02: Scroll Lock: off
    03: Compose: off 04: Kana: off 05: Sleep: off
    06: Suspend: off 07: Mute: off 08: Misc: off
    09: Mail: off 10: Charging: off 11: Shift Lock: off
    12: Group 2: off 13: Mouse Keys: off
    auto repeat delay: 660 repeat rate: 25
    auto repeating keys: 00ffffffdffffbbf
    fadfffefffedffff
    9fffffffffffffff
    fff7ffffffffffff
    bell percent: 50 bell pitch: 400 bell duration: 100
    Pointer Control:
    acceleration: 2/1 threshold: 4
    Screen Saver:
    prefer blanking: yes allow exposures: yes
    timeout: 0 cycle: 600
    Colors:
    default colormap: 0x20 BlackPixel: 0x0 WhitePixel: 0xffffff
    Font Path:
    /usr/share/fonts/X11/misc,/usr/share/fonts/X11/100dpi/:unscaled,/usr/share/fonts/X11/75dpi/:unscaled,/usr/share/fonts/X11/Type1,/usr/share/fonts/X11/100dpi,/usr/share/fonts/X11/75dpi,built-ins
    DPMS (Energy Star):
    Standby: 0 Suspend: 0 Off: 0
    DPMS is Enabled
    Monitor is On

  4. If set to 10 sec
    volumio@volumio:~$ xset -display :0 q
    Keyboard Control:
    auto repeat: on key click percent: 0 LED mask: 00000000
    XKB indicators:
    00: Caps Lock: off 01: Num Lock: off 02: Scroll Lock: off
    03: Compose: off 04: Kana: off 05: Sleep: off
    06: Suspend: off 07: Mute: off 08: Misc: off
    09: Mail: off 10: Charging: off 11: Shift Lock: off
    12: Group 2: off 13: Mouse Keys: off
    auto repeat delay: 660 repeat rate: 25
    auto repeating keys: 00ffffffdffffbbf
    fadfffefffedffff
    9fffffffffffffff
    fff7ffffffffffff
    bell percent: 50 bell pitch: 400 bell duration: 100
    Pointer Control:
    acceleration: 2/1 threshold: 4
    Screen Saver:
    prefer blanking: yes allow exposures: yes
    timeout: 0 cycle: 600
    Colors:
    default colormap: 0x20 BlackPixel: 0x0 WhitePixel: 0xffffff
    Font Path:
    /usr/share/fonts/X11/misc,/usr/share/fonts/X11/100dpi/:unscaled,/usr/share/fonts/X11/75dpi/:unscaled,/usr/share/fonts/X11/Type1,/usr/share/fonts/X11/100dpi,/usr/share/fonts/X11/75dpi,built-ins
    DPMS (Energy Star):
    Standby: 0 Suspend: 0 Off: 10
    DPMS is Enabled
    Monitor is Off

(. . . while it is on still. )

Best regards, J.

Yes, … had just the scaling in mind :wink:

The results of xset q show that the settings from the touch displays configuration page had been applied perfectly fine.

The screensaver of the touch display plugin relies on DPMS working. While I can’t say that your particular screen is affected, there seem to be some displays in the market where the DPMS implementation is “not OK”. I suggest to test the screensaver function using another HDMI monitor to rule out an issue with your display.

Just to clarify: With “still on” you mean the Volumio UI is still visible, right? Or is the screen black but its backlight is still on?

When I bought this DIY project DAC player, the purpose was to shortcut single component purchase with alle possible errors. However you do not exactly know what you get from SW maintainance point of view. :wink: But OK. What I do have is a 3.5 HDMI screen. I will try this.

Computer monitor may also have HDMI input. Alternatively try it with a TV.

Yes. It is as if there is no screensafer setting active. I glows and glows . . .

I will research a little the DPMS topic. May be post a message to waveshare if they implemented their part properly, but they’re known to leave post without reply (maybe simply because because helplessly under staffed).

I just saw there is a comprehensive discussion with user aardwolf about same topic.

I have no clue if it would have any effect but you may also try adding dtoverlay=vc4-fkms-v3d back to /boot/userconfig.txt. Restart would be necessary after doing so.

Yes, he tested with a TV and the screensaver worked as expected :wink:

I tried but it was only disabling screen. Or perhaps let it get frozen in a certain initialization state. I wonder if I have to increase graphic memory but I am afraid to loose systematic approach. When system initializes screen goes white and grey in almost flashing manner. I believe your early assumption of a poorly implementation dpms is not too far from truth.

Edit: I believe I misunderstood when I first read your post and now assume you referred to adding dtoverlay=vc4-fkms-v3d.

The screensaver just shuts off the screen (sets DPMS state “off”), so the displays simply goes black. I.e. the screensaver shows no graphics, images or the like.

You can increase GPU memory from the configuration of the touch display plugin.

That appears to be normal.

Did you have the chance to test with another HDMI connected monitor/TV?