Volunio 3: disappointment

Just a comment on Volumio version 3:
I have been and are running Volumio successfully on various versions of RaspPi – Zero, 3A+, 3B+, 4 – with and without DAC or Hifiberry MiniAmp, and a Synology NAS as primary source of music. One version works with a 7” Display.

The other day, I had been persuaded to upgrade this latter device from version 2.x to 3.x. A step that I deeply regretted :

  1. I do not see any advantage of 3.x over 2.x. On the contrary, almost all of my favorite plugins had disappeared, and the display resolution needed to be readjusted.

  2. It took me a hell of time to get the 3.x running in a fashion similar to the previous version.

Certainly, I refrain from upgrading the other devices. Rather, I’d like to fall back to version 2.x. Unfortunately, is no longer available and I missed to save a copy

5 Likes

I really don’t get this kind of comments.
The guys worked hard to improve Volumio in this version. According to many, there are improvements in audio quality and usability. Just because your favorite plugins are not there at the moment (let’s remember, they are works done by third parties) doesn’t mean that Volumio 3 is worse than the previous one.
The new plugin policy has been explained many times and has benefits in terms of security and stability.
The plugins you are looking for may be available soon.

8 Likes

@rovage_vol

Thanks for your feedback.

  • Can you please elaborate on which plugins you’re missing, as the majority have been ported?
  • What problems did you encounter when moving to v3?
2 Likes

To be honest, yes Volumio 3 didn’t have smoothest beginning, but this is the price of weekly / be-weekly updates. Whole software ecosystem is full of bugs. This wasn’t long ago when software was updated once or twice in a year. Betas and RC-s were tested and tested again. If I remember correctly Google started this “update as frequently as possible” thing with chrome browser. This kind of release schedule has very nice thing - new features are quickly available. Dark side of it is - these new features are not tested very much nor documented.

With such a small team Volumio developers have done great job to keep up with busy update schedule.

We will serve no software before its time…(its time!) …The update frequency that Google started is kinda nuts, imho.
I many cases, the releases are dictated by time and NOT adequate testing/verification before release (kinda like the MS approach - we let the users test it…)
IDK what the volumio folks do. I believe they maintain a good test strategy release versions after they have been well vetted, and not driven by a time table. From my perspective, what they have done is so far, so good…

IMHO the stability issue is more widespread. Personally I gave up on Volumio after many tests in my network. After upgrading to version 3 hell broke loose. The whole added “call-home” code is just too dominant now. I even tried to subscribe to test out the multi-room feature with no luck. But the worst issue was that after around 10 minutes of reboot, the player started to respond slowly to each command with the line on top going on for ever and only another forced reboot would allow me another 10 minutes of usable interface. Tried to reinstall a fresh version 3 on a formatted card but same symptoms would show up all with defaults settings, no plugins etc. just wired IP with disabled Wifi and hotspot features. Reserved DHCP IP was the only way at times to access player and mDNS would not show shairport presence nor volumio.local

Putting back version 2, none of the issues would surface. Btw, why do you make it so hard to download older releases.

One more thing, why would saved radio favourites just get wiped out on upgrade? Not good having to re-write all the URI’s from scratch or convert the file via SSH.

Hardware wise I don’t think I have such an exotic setup either. Common Pi with Allo Boss gen1. Also, same issue on 2 identical setups. So I tend to exclude any HW issues.

UI swap also not a clean experience, maybe due to the new visual being reserved for subscribers.

Will stick to Moodeaudio for the time being and I really would like to be proven wrong as I loved Volumio.

Is this a one off bad experience and everyone else is happily using the upgraded version. I just hope so.

1 Like

I’m relatively new to RPi, using a Topping 50 via usb, and Volumio 3. Have not used v 2. IN my experience, Volumio can take up to an hour to find the device, other times it comes right up. I’ve re-loaded the app and the RPi boot disk multiple times. IMHO, the management released the version too early, without sufficient testing.

I do not see any advantage of 3.x over 2.x

The FusionDSP plugin and the ManifestUI come to mind as two significant improvements. If they don’t appeal and you use other plugins then I might agree that you could be happier on 2.x until the v3 plugins catch up. I was pretty happy with v2.917 - I still have the RPi image if you can’t find it elsewhere.

@rovage_vol
You can find the last release of v2 here
https://updates.volumio.org/pi/volumio/2.917/volumio-2.917-2021-10-06-pi.img.zip

Its a shame you have gotten off to a bad start with V3.
What you must remember though most of the changes have happened under the hood. Required changes to bring the software up to date with the modern/different way of doing things which will pave the way for future development which could not have been possible with V2, just look at the superb FusionDSP plugin.
Problem with this sort of change is the introduction of bugs. It happens with most software that undergo this sort of update, its part and parcel of life nowadays

If you can…Back up…Update…If you dont like it Revert

Volumio 3 does seem to have some weird problems Volumio 2 didn’t have.
I’ve registered a Free account so I could use the webradiostations feature, yet I can’t play any webradio streams. Somehow my Free account not only fails to activate on my RPi 3 Volumio 3, it urges me to upgrade to a paid account. Well, no: if I can’t register my Free account and therefore miss previously included content, then why on earth would I pay money for an account? Who says that upgraded account will actually register?

Improving an existing product is fine, well, more than that: it’s really good. But if that improvement comes with all kinds of weird problems, then expect people to complain about that.

You don’t need a free (or paid) account to play webradio.
Are you sure of your network?
Are you sure of your password?
Did you send log?
What is your hardware?

1 Like

Yep, that was my understanding too, but ever since I updated to version 3.2XX the following features ceased to work:

  • update (spinning endlessly but never connecting)
  • webradio (both with and without an account)

I thought it was a bug in that release, but I’ve manually downloaded and installed a newer version twice now and the problems persist.

I’m using a Raspberry 3 with a HifiBerry Digi clone that has always worked flawlessly.
My network is working fine, I can still connect to everything on it and even the somewhat tricky connection from Volumio to my ReadyNas 1100 works fine.
I’ve deleted my account because I thought maybe something went wrong but that didn’t change anything. Then I re-entered my account, reset the password multiple times, did yet another clean install but nothing gives me access to either webradio or updates.

I haven’t sent in a log, because I don’t know how to do that.
I only use the Volumio UI remotely and the RPi isn’t connected to a screen, which hasn’t ever been a problem, even with the first 2 versions of Volumio 3 I’ve installed.

To send a log, go to http://volumio.local/dev/ (assuming that you are using the default server name) and find " Send Log or bug report" on that page. Enter a few words describing the problem and click “send”. In a few seconds the URL to the log report will appear in the empty field. Copy and paste that in your comments here.

The only problem with this process is that it requires the RPi to have internet connectivity, which is not always the case.

1 Like

Hi, many thanks for this link!
Download of v2.917 was successful, I will keep it safely. Just in case… :sweat_smile:

Thanks for the instructions.
It’s stuck on “Sending log report, please wait” for several minutes now.
It’s beginning to look like my RPi3/Volumio3 works properly in my local network but for some reason refuses to connect to the internet. The strange thing is that if I hit the “Help” or “Shop” buttons, they immediately open Edge and show the webpage. Interesting problem.

Is there any way I can locally check the error log?

Problem solved: for some weird reason instead of letting the player and router sort it out, I had to manually provide my player with a fixed IP, fill in the gateway IP and the network resets in Volumio and it works.
Never had this problem before with any version. Anyway, it works, I’m happy.
Thanks for your help.

1 Like

Not sure if it helps or not but it seems to me that Volumio is better suited for those who have experience with linux and a little networking or those who have no qualms about learning about those things. For me, Volumio is ideal. For my extended family and friends Volumio is ideal because I’ve done the setup for them.

All of my Volumio devices are the same. RP 3B+, HiFi Berry Clone, Lighted Pushbutton to toggle Off/On. I use 3 plugins only (GPIO Buttons, AMP Switch and Radio Paradise).

The only problems I had upgrading to Version 3 are:

  • That it blanked my favourite radios
  • It forgot my NAS and Playlists
  • It blanked my Userconfig.txt

I did have to build my GPIO and AmpSwitch plugins using the terminal window which makes having some Linux experience helpful but the instructions for missing plugins are well documented on the Volumio Forum, so aside from some digging around, it wasn’t particularly difficult to get my system back.

Since the version upgrade to V3 and the addition of my must-have plugins, I have updated Volumio several times without issue. Web Radio works fine, my NAS works fine, rebooting is quick and painless. I have zero complaints. Volumio 3 is the best Volumio yet and once all of the plugins are in place it will be even better. Now, if we only had an Amazon Music Plugin…

1 Like