Volumio3 broke realtek wifi with last update

Long story short:

We were forced to upgrade the kernel version for Raspberry PI, in order to support the latest model of Raspberry PI 4 v 1.5.
Unfortunately, for those newer kernels, there are no pre-built wi-fi drivers for dongles not already supported by PI. Those were built by a third-party which just stopped providing them.

We tried to support latest PI 1.5 by doing some tricks to retain wi-fi drivers, but it did not ultimately work.

So, we needed to make the choice: upgrade the kernel to support latest PI 4, or drop some wi-fi driver support. Considering that in the future we would have needed to upgrade the kernel anyway, we went for the first choice.

Of course, we could build and maintain those drivers ourselves, but it requires a substantial amount of work which we cannot handle at the moment, and we prefer to prepare a list of supported dongles that you can get if in need.

1 Like

Is there a way to roll back to prevuis version?

Good news! Can you already say which chipsets work? So I can try to find a matching dongle…

1 Like

We are waiting for feedbacks from the community…
@DED do you have any news on that? Do we know which dongles work so far?

I went back to 3.175, WiFi is working again

Small input from my side: on my way to the supermarket I passed a Conrad store and decided to check for available WIFI-Dongles and bought 2 cheap (sub 10€) dongles:

At home I found, that both have the RTL8188EUS chipset (thought one had a RALINK chipset in the store) which I can confirm to work :-).

As I only need one dongle: if someone (within Europe) wants the LogiLink send me a PM. It goes a little hard into the USB Port but works without problems.

1 Like

I have that TP LINK and I’m having problems

Strange. Mine is v3, maybe they changed the chipset?

any status update? I miss my music :frowning:

what about just using the same repos for wifi that libreelec is using? they all work fine with latest kernels,
take a look here LibreELEC.tv/packages/linux-drivers at master · LibreELEC/LibreELEC.tv · GitHub

rtl8112au - GitHub - aircrack-ng/rtl8812au: RTL8812AU/21AU and RTL8814AU driver with monitor mode and frame injection
rtl8192eu - GitHub - Mange/rtl8192eu-linux-driver: Drivers for the rtl8192eu chipset for wireless adapters (D-Link DWA-131 rev E1 included!)
rtl8192du - GitHub - lwfinger/rtl8192du: Source code for RTL8192DU device
rtl8192cu - GitHub - pvaret/rtl8192cu-fixes: Realtek 8192 chipset driver, ported to kernel 3.11.

Is that TP-LINK v3 working for you with 3.233 ?

Yes. Works

Does it say v3 or v3.8

Sticker on box says v3.0

1 Like

is there a way to rollback to last stable version without reinstalling?
i need 3.175


so thats not possible? is there any timeline for realtek going back or are you force to buy a new adapter?

Weird I bought a TP-LINK TL-WN725N V3 and it worked until there was no activity and then stopped working, like it went to sleep.

I did find one that works with the latest update. Hopefully it stays working with further updates.

I found its the same for me in the meantime, as I wrote here:

Works for some hours and then stops working…usually I only use the PI2 for a short period of time and always turn it off (as it is in a room I don´t listen to music a lot), so didn´t notice it before…

There does not seem to be a way that we can support the Wi-Fi drivers that got missing in the new kernel. Unfortunately you will have to get a new dongle.

What driver did you use in the past? I can you link it? Does it install as a Deb?

edit: using version 3.245
doing first: volumio kernelsource
download GitHub - aircrack-ng/rtl8812au: RTL8812AU/21AU and RTL8814AU driver with monitor mode and frame injection

make && make install
modprobe 88XXau

and voila, it worked.
I have no knowledge about your build system but this repo and the others used by libreelec is very much working with newer kernels.