Volumio3 and ext4 USB thumb drive permissions problem

I have been using Volumio with external thumb drives for some time now and have always formatted them as FAT32. I decided that ext4 would be better (as I do have some special characters in my filenames). However, although my ext4 disk mounts quite happily, Volumio cannot see it (although the files are there if I ssh in and use

sudo ls

So before I insert the disks my file structure looks like:

drwxrwxrwx 2 volumio volumio 1024 Feb 14 14:12 PI4MUSIC
drwxrwxrwx 2 volumio volumio 1024 Feb 14 14:12 PI4RIP
drwxrwxrwx 2 volumio volumio 1024 Feb 13 23:51 TEMPRIP

and after I insert the thumb drives

drwxrwxrwx  8 root root 32768 Jan  1  1970 PI4MUSIC
drwxrwxrwx 54 root root 32768 Jan  1  1970 PI4RIP
drwx------ 54 root root  4096 Feb 14 13:08 TEMPRIP

The first two disks are formatted FAT32, the 3rd ext4. So it looks like a permissions problem as only root can read the disk. At the next level down i.e. the directories that hold the albums, the permissions are fine i.e. every directory and file is read and writable by everyone (and owned by root). I did see another post about auto mounting not happening but my problem seems different (as my disks are auto mounting). In the solution there, it was suggested that a diagnostic is

sudo parted -s /dev/sda unit MB print
Model: SanDisk Ultra Fit (scsi)
Disk /dev/sda: 124219MB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags:

Number  Start   End       Size      File system  Name      Flags
 1      1.05MB  124217MB  124216MB  ext4         SPARERIP

Don’t know if this helps but I welcome your suggestions as to how to make automount mount as world rwx for ext4 volumes as it does for FAT32

Many thanks

Andrew

I recently had a similar issue on my Volumio running on a Raspberry Pi 4.

I had formatted a USB 256Gb thumb drive as NTFS and copied all of my albums and tracks to it. My goal was to replace the existing smaller thumb drive. I used NTFS so I could copy the files to the new drive using a Windows 10 environment, as I am unskilled in Linux and its derivatives and barely functional using SSH.

I figured that if I shut down Volumio properly, removed the old drive and inserted the new one, Volumio could be asked to rebuild the library from scratch when rebooted. Needless to say, this did not work. Volumio would not even recognize the thumb drive despite numerous reboots. So I tried reformatting it in FAT32, but that made no difference. Each time I asked Volumio to rebuild the library it saw no data and artists, albums, and tracks count remained at zero.

I put it back into NTFS format and before adding all my music to it I added only a few folders, files, and tracks as copying my whole library takes hours. Again, Volumio refused to even “see” the drive. In frustration, I decided to see if Windows 10 file explorer could see the drive by connecting to the server built into Volumio.

I typed “\\volumio” into the file explorer’s address bar and immediately saw 3 folders; Internal Storage, NAS, and USB. Clicking on USB it expanded into folders that were NOT representative of what I had actually copied to the USB thumb drive! Rather, they represented what the old thumb drive had on it.

So I took the bold step of telling windows Explorer to delete the files that Volumio said were on that thumb drive.

Then, I rebooted the Pi4 and everything worked. I could specify “Rebuild Library” in “Settings/Sources” and everything showed up and played fine. So, I went back and using Windows File Explorer I copied the rest of the music files to the Volumio from my “Master” library that is kept on a NAS Server.

Once the copying was finished I had Volumio rebuild the library again and now everything works as it should. The USB thumb drive is recognized and plays any and all the tracks, displays the album covers, and sorts by artist or whatever I specify.

So, it seems that Volumio can read NTFS, FAT32, and FAT formats just as well as ext4, but you may have to delete the files that Volumio “thinks” are on the drive before adding all the new data. I had no luck doing that from within the Volumio UI, I had to acess the USB drive using Win 10 File Explorer and delete the files (even though they were not really there) on the thumb drive plugged into the Volumio USB3 port.

Now, when I make a change to my “Master” library on the NAS, I use a program called “Beyond Compare” from Scooter Software to compare the Master with the USB in the Volumio over my home network. The program shows me all the differences between the two libraries and lets me sync the master with the USB in a few clicks. That has worked for a while now and is very quick and convenient.

Did I finally go mad…

Similar behavior with a rPi3 and Samsung 860 EVO mSAT SCSI, formatted as FAT32.
Moved files from a TS-341P via a windows PC to the disk.
image

On connection with the rPi3, Volumio V3.226 the disk gets mounted but Volumio thinks it’;s empty.
If I connect to the disk via \\<ip-address>\USB\ the drive shows empty
image

and I can copy a folder that already exits to the drive.
image

image

Volumio now see this folder:

So I remove the USB disc and Volumio still shows the folder and I can even play the audio???
image
No clue where these files went…

---------------------------- MPD announces system playlist update
info: Ignoring MPD Status Update
info: ------------------------------ 93ms
info: sendMpdCommand add "USB/Aswad/(1976) - Aswad/1005 - Aswad - Back To Africa.flac" took 88 milliseconds

info:
---------------------------- MPD announces state update: player
info: ------------------------------ 76ms

In the end I just did

sudo chmod -R a+rwx /media/SPARERIP 

and that seemed to work and persists over a reboot

Andrew