volumio2, overlay shows only 415 M while partition 3 is 30GB

I need help fixing this. Volumio2 on cubix-i4. Partition expansion seems to correctly put the rest of the space to partition 3 but overlayfs is still very small and when I transfer files to /data/INTERNAL it confirms that it is indeed very small (only able to put in about one album of flac files, and then no more space).

volumio@volumio:/data/INTERNAL$ df
Filesystem Size Used Avail Use% Mounted on
overlayfs 415M 362M 27M 94% /
/dev/mmcblk0p2 2.4G 534M 1.7G 25% /imgpart
/dev/loop0 265M 265M 0 100% /static

volumio@volumio:/data/INTERNAL$ sudo parted -s /dev/mmcblk0 unit MB print free
[sudo] password for volumio:
Model: SD SU32G (sd/mmc)
Disk /dev/mmcblk0: 31915MB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags:

Number Start End Size Type File system Flags
0.03MB 1.05MB 1.02MB Free Space
1 1.05MB 64.0MB 62.9MB primary fat16 boot, lba
64.0MB 65.0MB 1.05MB Free Space
2 65.0MB 2500MB 2435MB primary ext4
3 2500MB 31915MB 29415MB primary ext4

Please enlighten me as what could be the problem since I am not too familiar with the advanced filesystem with the dynamic part.

Thanks in advance.

Did you manually change anything after flashing the image and before first boot?

No I did not.
I did try to turn off wifi thru the web menu but it came back on and I have not tried to turn it off again.
Other than that I tried to enable ssh (succeed), but I only used it to investigate the partition (using df for example).
Is there any config file that I can report to diagnose the issue?


which version of the image are you running?

I am at work now so can’t look at it directly but it was downloaded last Sat/Sun, and on Sun I checked for update and it said that it was the newest version.

this is the image I used:

I use another 32GB sdcard and redo from start. This time doing nothing other than loggin in directly using usb keyboard and hdmi out to tv.
Did df and fdisk -l.
Same result as above only 415 M overlay
seems like the overlayfs did not get connected to the #GB partition that is mounted as /dev/mmcblk0p3

Hope that info give you some clue.

This is getting stranger by the day.
I will show what I get after flashing and booting from an 8Gb SD card on a cubox-i2ex.
There is no reason why it should be different on a cubox-i4.
Can you please compare this with yours, so we are absolutely sure we’re looking at the same versions:

volumio@volumio:~$ df
Filesystem      Size  Used Avail Use% Mounted on
overlayfs       5.3G   15M  5.0G   1% /
/dev/mmcblk0p2  2.4G  534M  1.7G  25% /imgpart
/dev/loop0      265M  265M     0 100% /static
devtmpfs        389M     0  389M   0% /dev
tmpfs           526M     0  526M   0% /dev/shm
tmpfs           526M  4.9M  521M   1% /run
tmpfs           5.3M  4.1k  5.3M   1% /run/lock
tmpfs           526M     0  526M   0% /sys/fs/cgroup
tmpfs           526M   17k  526M   1% /tmp
tmpfs           526M     0  526M   0% /var/spool/cups
tmpfs            21M   17k   21M   1% /var/log
tmpfs           526M     0  526M   0% /var/spool/cups/tmp
/dev/mmcblk0p1   63M   13M   51M  20% /boot
tmpfs           106M     0  106M   0% /run/user/1000
volumio@volumio:~$ cat /proc/version
Linux version 3.14.79 (cubox@VolumioOS) (gcc version 4.9.3 20141031 (prerelease) (Linaro GCC 2014.11) ) #2 SMP Sat Jan 28 19:39:16 CET 2017
volumio@volumio:~$ cat /etc/os-release
PRETTY_NAME="Debian GNU/Linux 8 (jessie)"
NAME="Debian GNU/Linux"
VERSION="8 (jessie)"
VOLUMIO_BUILD_DATE="Sun Mar 26 18:12:54 CEST 2017"


I am typing mine since ssh does not work. Don’t know why and it’s very late now.
essentially the same as yours except for the memory amount part. My cubox-i4 has more memory, but overlayfs is smaller (the confusing stuff).

root@volumio:~# df
Filesystem Size Used Avail Use% Mounted on
overlayfs 415M 362M 27M 1% /
/dev/mmcblk0p2 2.4G 534M 1.7G 25% /imgpart
/dev/loop0 265M 265M 0 100% /static
devtmpfs 1.9G 0 1.9G 0% /dev
tmpfs 2G 0 2G 0% /dev/shm
tmpfs 2G 5M 2G 1% /run
tmpfs 5.3M 4.1k 5.3M 1% /run/lock
tmpfs 2G 0 2G 0% /sys/fs/cgroup
tmpfs 2G 17k 2G 1% /tmp
tmpfs 2G 0 2G 0% /var/spool/cups
tmpfs 21M 54k 21M 1% /var/log
tmpfs 2G 0 2G 0% /var/spool/cups/tmp
/dev/mmcblk0p1 63M 13M 51M 20% /boot
tmpfs 398M 0 398M 0% /run/user/0
root@volumio:~# cat /proc/version
Linux version 3.14.79 (cubox@VolumioOS) (gcc version 4.9.3 20141031 (prerelease) (Linaro GCC 2014.11) ) #2 SMP Sat Jan 28 19:39:16 CET 2017
root@volumio:~# cat /etc/os-release
PRETTY_NAME=“Debian GNU/Linux 8 (jessie)”
NAME=“Debian GNU/Linux”
VERSION=“8 (jessie)”
VOLUMIO_BUILD_DATE=“Sun Mar 26 18:12:54 CEST 2017”


and you really just flashed the image to an SD, synced (linux) or properly ejected (pc), took it, stuck it immediately in the Cubox and booted, nothing like manually resizing?
That would be as good as impossible (but I guess there is a first for everything).
First thing happening at boot time is creating the factory backup, resize the data partition and mount it all as part of the overlay fs. I don’t get why overlayfs does not span the rest of the disk in your case…

Correct. Even tried it the second time to make sure that I did not do to much (for the first one I enabled ssh, and tried to turn off wifi from the local html interface). Seceond one I did not do any of those. The result is the same.

Is there any way to check what is wrong with overlayfs form other file(s)?
fdisk -l shows the 27.4GB partition on /dev/mmcblk0p3. Is this the expected behavior?
df does not show this partition.

Or is there any way to tell it to redo the expansion manually (libreelec will redo the expansion if we touch a certain file - /storage/.please_resize_me). Is there a way to do this in volumio.
Can you tell me if the resize partition step has actually been done (from the fdisk -l result) ?

More info:
Looking at /etc/mtab I see this:
/dev/mmcblk0p3 /mnt/ext …

overlayfs / overlayfs rw, relative, lowerdir=/mnt/static, upperdir=/mnt/ext/dyn

So I am expecting to be able to do this:
cd /mnt/ext but the directory is not there.

Does this mean that mmcblk0p3 did not really got mounted?
BTW which process / config did the mounting of mmcblk0p3?
Neither 0p2 nor 0p3 are in /etc/fstab.

Does this give you any clue?

fixed using gparted in my desktop.
Will update later if the fix is stable.

same issue here on a PI2 on 2.246 but in mtab no p3 partition.

/ is full … and in fdisk p3 is 5GB, please help !

looks like this is solved by:
sudo resize2fs /dev/mmcblk0p3

(previously was only 272M instead of 5G)

Same issue, gparted under my ubuntu 18.04 laptop and run Partition menu then check (Vérifier in french) and it is solved, more than 50Gb of my 64Gb SD card intead of 245Mb