Volumio2 equalizer plugin

After a long wait, I uploaded a new new plugin “Volumio Simple Equalizer”.
It provide a “one click” configuration (just enable the plugin) and you’ll get a 10 bands equalizer with preset.
This a beta version and may not work as expected :wink:
NOT compatible with Softvol !
May not work with kali reclocker (need some tweaks)
Feedbacks welcome !
Enjoy ! :smiley: (if it works for you)

source : github.com/balbuze/volumio-plug … impleequal
file to download : github.com/balbuze/volumio-plug … eequal.zip

1 Like

Well done Balbuze; I think this was one of the most requested feature requests by a long way.

Hi Balbuze and thanks

To my movie sound system I’m using a plain Rpi3 without any DAC just HDMI sound , the system is a bit poor when it comes to fine tuning, it works nicely with movie and tv sound , also works fine with “simpel” sounded music but when it comes to more “complex” sound like heavy metal I do need something to cut some edges off. :slight_smile:

When I activate the plugin the sound disappears, tried both HDMI and Audio jack , and a reboot in between and after changes.
Using version 2.206 and 0.0.8 of the plugin

Bless you

I didn’t test it (yet) with hdmi or jack. I suspect the flow format to be adjusted for this output. Have a look at "sudo journalctl -f to see if alsaloop fails to start (f you can). I can’t check until tonight…

Hi balbuze, thanks your great support, already enjoying with your birtfir 2 plug-in on rpi3 +Allo boss on volumio 2.209 version. Last night I have uploaded this plug-in without distrubing previous setup. But no luck, volumio was crashed, found error message in the ui after restart. Any guesses.


Have you disabled brutefir before using volsimpleequal? What is the error message?

No, brutefir2 not disabled, showing error_not connected and blank screen.


Hi Balbuze

It works now ! :slight_smile:

After activating the plugin and 2 reboot it works , I’m using hdmi at the moment

Bless you

Good !
Anyway, I upload a new version that should be ok with jack and other output…
I tested it with a rpi2 , jack output mpd and volspotconnect2.
I can’t test hdmi, but let me know.

The version uploaded tonight should fix most of issues…
let me know
If you have a previous version, please remove it and remove /etc/asound.conf

sudo rm /etc/asound.conf

repo : github.com/balbuze/volumio-plug … impleequal
file to download : github.com/balbuze/volumio-plug … eequal.zip

I have installed the new version and hdmi works fine (after 2 reboots)
What I have noticed is some silence in the stream (1-2 seconds long) that comes in waves, 2-5 minutes okey then 2-3 hiccups with in 30 seconds

When cuting down the midrange levels even metal sounds decent ! :laughing:

Hi Balbuze

Been testing a bit but I can’t make it work properly,
the actual equalizer works fine when I manage to get some sound!

When I disable the pluging or uninstall I have extreme difficulty to get it work when I reinstall. (right now I’m not able to get it work again)
Volume is some times stuck to 100.
I can’t browse the music lib (browse menus is empty).
1-2 seconds of silence in waves.
Playlist stops playing (using a large playlist for testing)

Keep up the good work and let me know when you have a new version

I’m testing on a player when using HDMI , if you like a can do “Newbie” tests on players with Hifiberry Dac’s

Bless you

When you disable the plugin, you have to reconfigure volumio to get the sound working. Save the output and the mixer. Test with a track. Once it is done, enable the plugin and wait few seconds. Test. If no sound, do not disable the plugin, but reboot. Let me know

I noticed that sometime the installation of libasound2-plugin-equal install nothing… And of course the plugin can’t work.
Reinstalling the plugin seems to be ok…
I have to investigate

Hi Balbuze

Thanks for your answer
Haven’t had time to do a new install , but will try again during the weekend

Just a note on Uninstalling the plugin

The uninstall process got stuck on 90 , waited for at least an hour , removed the /etc/asound.conf, rebooted and tried a reinstall but after that I didn’t got any sound when the plugin was aktive.

Note2 I have installed and uninstalled both 0.0.8 and the newer version and had sound out of both versions, but after uninstall of the newer version I got stuck ! :slight_smile:
Bless you

Hi Balbuze

I’ve been testing back and forth, upside and down
I have installed version 0.1.3
I can deactivate the plugin and get the Hdmi sound to work,
but not activate the plugin again and get some sound out of the equalizer

When the plugin is active:
On Playback options menu:
Audio output / Save don’work
Playback Options / Save don’t work
Volume Options / Save works

When clicking the Playbutton, it don’t indicate that something is playing

Bless you
Playback options.png

Try the following:
Disable the plugin
In playback settings, choose the output you want (not Loopback) and save
Select the mixer you want if any and save.
If you use a i2s DAC, enable i2s and reboot.
Play a track to check it works.
If ok enable the plugin. Don’t change anything in volumio settings !!! Or you will break the config and you’ll have to restart from the beginning…
Let me know

Thanks Balbuze !

You should know that you sometimes is dealing with morons and “DO NOT” instructions is the only thing that makes them think! :slight_smile:

Working fine now , I also figured out what’s buging me in my TV soundsystem , It’s the 1Khz sound that make’s funny stuff in my ears.

Bless you

Hi Balbuze

I have updating my players and the update from 2.20X to 2.222 worked fine, the plugin was active during the update and worked after.
But after the update to 2.233 I’m stuck again!
Any known problems ?

Bless you

I’m using this version. Try to reboot. If still no sound, disable the plugin, set your DAC in volumio. Test with a track. If ok enable the plugin. Test with a track. If no sound reboot… And of course, don’t try to change the output in volumio after you have enable the plugin. Let me know.