Volumio2 Development Introduction

Question: Will Volumio 2 have full X loaded? Can it have X loaded on it without breaking it?

The xev and xbidkeys method to remap mouse input to shell commands you get with full X should let any USB X device (eg. five button scroll wheel mouse) be a complete wired controller for their Volumio 2 node.

Guess no hope for V2 this year.

Oh well…Merry X-Mas anyways, hope you all find something fun the play with this holiday

I have tried the BETA image. On boot I get to about 10 seconds on both an original RPI B and A+ before I get the message that the Volumio data partition is missing please create it. I eventually hangs with a kernel panic.

What am I missing?

I downloaded the image and the dd it to the SD card with a variant of sudo dd bs=1M if=[img_file_path] of=/dev/[sd_name]

I get the same error, also with a kernel panic as last error, this is on an rpi 1.0B

Looks like the error is already reported here:

@Atca and Bjarke:
this problem has been resolved, there is a new beta version available for downloading or to build with the Volumio Builder.
Currently that version works fine with a 4 or 8Gb SD card.
For bigger cards you will have to hold until tomorrow as that issue is currently being fixed, which can take a few hours.

@gkkpch thanks using a 16gb card here

Did the 8Gb+ issue get fixed?

yes we have a working solution and is going to be published soon for people who use the build scripts.
A new beta version will follow also.
Everything takes a bit longer because of the festive season, please understand.

Guys. Is the beta working on RPi Zero? Version 1.55 didn’t even boot :frowning:

(via Tapatalk)

Sorry, no support for PI Zero yet.
As soon as someone sends me one (or offers me one for 5$), I’ll create a build script for it :laughing:

Current Volumio 2 support: pi (A/ A+/ B/ B+/ PI 2), udoo, cubox-i, udoo, udoo neo, odroid c1/c1+, odroid-x2, odroid xu4 and X86 (PC)

I hope that support for Raspberry Pi Zero will be also there :slight_smile:


can someone explain how to use the build script in Fedora?

Dependencies are not are not easily available from fedora repos? (multistrap qemu-user-static binfmt-support)

Or could someone upload a working v2.0 beta 2 for arm?


Hi Florian,
Even after getting all dependencies, it still might fail because of the multistrap and qemu Versions.
That was my experience with Ubuntu, not worth the effort.
Changes are being committed at the moment, so you may have to wait another couple of days before an updated release PI Image has been uploaded.

The work of last couple of days has been mainly to support devices with 512MB of RAM… So yes, we just need the latest kernel and we’ll be there…

Does that mean support for the 256Mb raspberry pi’s will be dropped? Or is that for later development? (rev 1 B, A, A+)

I guess the ram disk wouldn’t be an option on those.

What kernel using Volumio 2.0? :bulb:

Volumio2 works on Kernel 4.06

The reason for having at least 256 MB of RAM is that the system runs ENTIRELY on RAM… Since the current system is 240 megabytes, and it requires more or less 100 of RAM (and other 16MB are reserved for video) the bare minimum to have a stable system is 512MBs

I just downloaded the the beta image on github to test it.

I noticed that it gives a Kernal Panik if I used the pi where I had a Hifiberry attached.
Using just a Pi it loaded with no issues.

I also noticed that under settings and System Update there is a reference to the AxiomAir

Reset your AxiomAir to factory Settings

Very excited about the new development. Especially when I saw a section for multi room audio.
But for now for my daily listening I’ll stick with 1.55 until Hifiberry Dac is supported

Roughly where is Volumio2 in the dev cycle? I see there is an Alpha 4 release. Is there consensus on when to expect a first general available release?

Check this comment of the project lead