Volumio X86/ Debian Buster debugging party (BETA)

I got on my laptop Samsung X420 (it was running fine) , os 2.756/ 2.861, the next error:
Failed to start load/save rf kill switch status.

What to do?

…I started over again , deleted partition with windows shell, now installing 2.857 again will let know what the results are

well, one step at the time please!
As long as you can’t tell us more about your configuration and not submit a logfile, then sorry, no help. I don’t like guessing people’s issues…

Inxi from version 2.861: The Inxi -VFzxxx command is not working only Inxi

CPU~Dual core Intel U4100 (-MCP-) clocked at 1300 Mhz
Kernel~3.18.25 i686 Up~27 min
Mem~370.0/2972.5MB
HDD~120.0GB(1.1% used)
Procs~139 Client~Shell inxi~2.1.28
System: Host: volumio Kernel: 3.18.25 i686 (32 bit)
Console: tty 0
Distro: Debian GNU/Linux 8
Machine: Mobo: SAMSUNG model: X420/X520
Bios: Phoenix v: 05IA.M008.20091015.KSY date: 10/15/2009
Network: Card-1: Realtek RTL8101E/RTL8102E PCI Express Fast Ethernet controller driver: r8169
Card-2: Qualcomm Atheros AR9285 Wireless Network Adapter (PCI-Express) driver: ath9k

I used the 2.2857 version for the log file.

Here is the result of the aplay commands:

aplay.txt (3.5 KB)

The log file I send within the browserpage volumio.locol/dev, there I send the log file

This are the errors I created but that is on version 2.861 not the beta. And by the way I am not a IT specialist I am researching now for 2 full days. I am runnign a trial now so if I am not satisfied I can go back to Roon It Is pure a hobby for me to help you out.
So hope you are have enough info now:

Here the log about wired an wifi problem:

log .txt (19.3 KB)

I’ve similar issue to Tecko’s

Ok, wired and wireless issues are known from the released versions, upto and incl. 2.861.
This is because Volumio for x86 is based on Debian jessie, which has an old kernel, lacking drivers and firmware for intel and amd hardware from the last couple of years.
In short: the newer the hardware components, the bigger the chance that graphics, touch screens and networking won’t work with Volumio.

That is why we have been working on a new version for quite a while, it is part if a bigger beta rollout which is upcoming for PIs, Tinkerboard and x86 (other portings may follow).

Back to Tecko’s issue.
Please forget 2.861, from your configuration info I can see wired and wireless cannot work.
You wrote, wired works with my linked beta 2.857 download, this was to be expected.
Wireless should be ok as well, in case it isn’t: beta image 3.036 now holds the latest linux kernel with the correct drivers and firmware for all currently supported network components with linux.

You mentioned, that you had another issue, indexing your music library, not being able to connect your NAS.
This is likely a configuration issue, where I needed the log for.
I requested the URL that has been returned when you pressed ‘send’. You did the log, but did not post the URL. Without it I have no access and cannot look, sorry.

oh thx for the info. Damn I forgot to post the url did get that, I am sorry. I am runnig now 2.861 with wifi. I wil try the 3.0 later and when I find something I do not forget to post the url.

Installed 3.036 after install database NAS was not scanning but after reboot it does. But I got a plugin error so I can not install spotify plugin:
Wired and Wireless are both working.

error: Cannot download Available plugins list: Error: got 404 response

Thanks.
Plugins will not be available yet, but are coming.
See a few posts above

I find out one more thing. I can not migrate usb to SSD because in settings->system it is not available to install on SSD.
I do not get it to work with command line. Do not know what image name to put in.

Correct, but I have no idea why the function has been disabled.
Anyway, as the copy function had issues and was way too slow, it had to be re-factored sooner or later. It is on my to-do list.

The instructions for flashing it manually are on the forum.

I am stopping trying takes to much time, the instructions do not work for me. Maybe I buy a nuc or primo in the future. Not shure which is the best option.
What is the best option know running 3.036 from usb or 2.861 from ssd on my laptop?

… running now 2.861 on ssd the best option for me for now, it is stable , but only with wifi but that does not metters. When there is a new stable release I wil install it. Thx for youre support gkkpch.

graag gedaan :wink:

I have installed 3.037 on NUC8i3BEK using an USB no problem. It now recognizes the ethernet network interface !! Wireless interface as well after I disabled Hotstop. Strange…
IMG_20210224_172913
Mounted my Synoloy NAS drive but no music files displayed even after multiple updates and rescans - even reboot.


There am I, stuck, but at least network interfaces are working now on my NUC8i3BEK.

After an hour or so, the music/audio files magically became visible in the volumio interface…
I am know listening through the built-in NUC analog audio interface with headphone. Not bad !!
Next test will be with with a Denon PM50 DAC amplifier.

Does 3.037 have the plugins now working? Can you post 3.037?

On version 3.036 my network is working Wired and Wireless. Thought my nu had no wifi but it works.
This is my config. Only plugins not working.

System:
Host: volumio Kernel: 5.10.9 x86_64 bits: 64 compiler: N/A Console: tty 0
dm: N/A Distro: Debian GNU/Linux 10 (buster)
Machine:
Type: Mini-pc System: Intel Client Systems product: NUC10i3FNH
v: K61343-302 serial: Chassis: Intel Corporation type: 35 v: 2.0
serial:
Mobo: Intel model: NUC10i3FNB v: K61362-302 serial: UEFI: Intel
v: FNCML357.0032.2019.1021.1624 date: 10/21/2019
CPU:
Topology: Dual Core model: Intel Core i3-10110U bits: 64 type: MT MCP
arch: Kaby Lake rev: C L2 cache: 4096 KiB
flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 20799
Speed: 3794 MHz min/max: 400/4100 MHz Core speeds (MHz): 1: 3727 2: 3839
3: 1309 4: 3702
Graphics:
Device-1: Intel driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:9b41
Display: tty server: X.org 1.20.4 driver: modesetting unloaded: fbdev,vesa
tty: 80x24
Message: Unable to show advanced data. Required tool glxinfo missing.
Audio:
Device-1: Intel driver: snd_hda_intel v: kernel bus ID: 00:1f.3
chip ID: 8086:02c8
Sound Server: ALSA v: k5.10.9
Network:
Device-1: Intel driver: iwlwifi v: kernel port: 3000 bus ID: 00:14.3
chip ID: 8086:02f0
IF: wlan0 state: up mac:
Device-2: Intel driver: e1000e v: kernel port: efa0 bus ID: 00:1f.6
chip ID: 8086:0d4f
IF: eth0 state: up speed: 1000 Mbps duplex: full mac:
Drives:
Local Storage: total: 119.25 GiB used: 1.92 GiB (1.6%)
ID-1: /dev/sda vendor: Kingston model: SA400S37120G size: 111.79 GiB
speed: 6.0 Gb/s serial: rev: 0102 scheme: MBR
ID-2: /dev/sdb type: USB model: USB DISK 2.0 size: 7.46 GiB
serial: rev: PMAP scheme: GPT
Partition:
ID-1: / size: 4.38 GiB used: 36.5 MiB (0.8%) fs: overlay source: ERR-102
ID-2: /boot size: 170.8 MiB used: 57.4 MiB (33.6%) fs: vfat dev: /dev/sdb1
Sensors:
Missing: Required tool sensors not installed. Check --recommends
Info:
Processes: 180 Uptime: 2m Memory: 7.50 GiB used: 470.8 MiB (6.1%)
Init: systemd v: 241 runlevel: 5 default: 2 Compilers: gcc: N/A
Shell: bash v: 5.0.3 running in: tty 0 (SSH) inxi: 3.0.32

3.037 does not show any plugins on my NUC8*. No idea how to make them work.
image

i tried to intsall it with github. But than you can only install commands from command line. I am testing it and trying to figure it out how it works. I am stuck on this, how to solve this is above my powers :wink:

Installing Spop and libspotify
amd64
–2021-02-25 19:25:01-- http://repo.volumio.org/Packages/Spop/spop-amd64.tar.gz
Resolving repo.volumio.org (repo.volumio.org)… 136.144.176.248
Connecting to repo.volumio.org (repo.volumio.org)|136.144.176.248|:80… connect ed.
HTTP request sent, awaiting response… 301 Moved Permanently
Location: https://repo.volumio.org/Packages/Spop/spop-amd64.tar.gz [following]
–2021-02-25 19:25:02-- https://repo.volumio.org/Packages/Spop/spop-amd64.tar.g z
Connecting to repo.volumio.org (repo.volumio.org)|136.144.176.248|:443… connec ted.
HTTP request sent, awaiting response… 404 Not Found
2021-02-25 19:25:02 ERROR 404: Not Found.

tar: /tmp/spop-amd64.tar.gz: Cannot open: No such file or directory
tar: Error is not recoverable: exiting now
rm: cannot remove ‘/tmp/spop-amd64.tar.gz’: No such file or directory
chmod: cannot access ‘/etc/spopd.conf’: No such file or directory
Linking libsox if required
ln: failed to create symbolic link ‘/usr/local/lib/libsox.so.2’: Permission denied
plugininstallend
volumio@volumio:~/volumio-plugins/plugins/music_service/spotify$

FYI: I am closing this thread, anything version older than 3.0.40 will be obsolete and unsupported!
We are preparing an official beta with new images, the announcement will come within the next 2 days.
Please read the announcement carefully as we expect testers to stick to certain rules.

EDIT: Please note: this topic has now been closed.

pre-versions numbered “3.0nn” can be updated to official betas without reflashing.
For update instructions, set test mode and update.
Note: anything lower than 3.040 is a still a pre-version!