Volumio X86/ Debian Buster debugging party (BETA)

You are free to use any player software you like.
My debugging has not finished yet, I do this unpaid as a volunteer in my free time. At the moment there is too little of that.

Btw. You pay for myVolumio, not for the free Volumio software, which this beta is an (unsupported) part of.

I’m here because for the supported (production) version you need 5 year old hardware.
Anyway, nothing personal.

This is a topic about improving Volumio support for x86 devices. As I’m sure you’re aware, x86 devices are extremely varied, and changing at a considerable pace. This can/does cause problems, especially if specific kernel versions are required for the hardware. We are trying to work through these changes to allow Volumio to provide the experience that everyone wants. If you have a problem with your MyVolumio subscription, then you should address it to the appropriate place, rather than bring it into this general Volumio topic please.

I guess most users do not understand how myvolumio and volumio interacts… One is a payed subscription… And if I have an issue from where I can get support? And I will get support only for payed features (example :tidal in user interface or qobuz… ) ? And the other thing if I install only volumio then I guess I will post here if I have an issue because this is open source and the work is done by volunteers.

Hi Lintbf,

yes I agree with you. If you have an issue with Volumio x86 then by all means post it here … MyVolumio subscriber or not. This post is directly supporting the basic Volumio support for x86, and ultimately MyVolumio too.


No Plugins!!
i installed Volumio x86 Buster, 2020-02-27, 0.007 on NUC8i3BEH, external USB drive, and that is working, i can get to log screen. ( different problem: Nvme0n1 boot is telling me cant initialize volumioboot UUID="3e9b6253… something, but that is another problem.)

anyway, when in Volumio (usb stick), i have no plug ins? i have internet on LAN working, checked searching radio stations.

I have disabled WLAN, Internal Audio, internal DSP on bios, also dont have it connected to DAC at the moment, but these probably shouldn’t matter.

here is my log:

im gone try test mode next, cause there seems to be an update to 2.781, will report if this helps soon…

yes, tried this update but nothing changed, even settings say it is still 0.007,

anyhoo, i’m gone try installing the latest version later today, maybe it will help

Meanwhile, don’t know how to take this into clipboard from Volumio, so took a picture of

inxi -vFzxxx, aplay -l, aplay -L results…

There are a few odd things with this NUC hw version (also have not seen anyone use it yet). inxi does not show any audio devices, which is unexpected, perhaps this due to missing firmware, I have to check the specs of NUC8 to see if Intel added something new.
Please use ‘aplay -l’ (lower case L), looks like you used upper ‘i’…
X86 Buster needs an update, this is planned but did not reach the top of my list yet.

thank you for so quick replay!

ok, i’m almost done installing the newest version, i added Onboard audio, dsp, wlan, hdmi audio in bios, so debugging maybe will show more info.

will do lower case.

Sorry, this is still beta, you cannot update to 2.781 because I did not generate one. 2.781 is for the released “legacy” X86 version (jessie).

ah yes, i installed 2.775 now. got it running, but no plugins still, Int. Radio works. Maybe i need to add some url somewhere and download defaults plugins into it?

debug is here http://logs.volumio.org/volumiobuster/j0qejFV.html

after install, i tried:
Installing to nvme0n1 from system menu, this time nvme0n1 got to 100%, but then it said; failed, cannot prepare system for resize.

after reboot i noticed this in loading pic., almost like it is using part usb stick/ part nvme0n1 to boot?
and i’ve always tried with nvme0n1 having same boot folders on anyway, maybe i should take out nvme0n1 from nuc, and use usb stick only, perhaps this solves plugin problem.

aplay and stuff

limited to 3 posts, so ill add final replay here:

very much appreciated, would only need to render spotify to nuc if all possible (air/upnp thing), or spotify2connect.

if Usb would work fine in future, im OK.

If there is anything else simple i can send, like go there, type this and that, i’m happy to help,


I’ll have a closer look to it, may take some time.
Log is very helpful, audio devices as expected.
Need a little time.
And for plugins, I’m not even sure if anyone made/compiled/tested one. I never needed/ used one. I’ll pass on the question…

I have not tested copy to nvme lately, so need to check that as well. There are more reports on failed disk-to-disk copy and we have plans to rewrite it…

Plugins: this would be because we are running the buster test version as a different volumio “variant”, causing the plugins not to show up.
We missed that, the next test version should fix that, ofc we have an interest in having plugins tested as well.

1 Like


i got nvme0n1 working!!!

first, i did new flash boot usb drive in windows, because i messed around too much somewhere…

then i used the method with 2 usb sticks, as before,

but nvme0n1 got stuck in legacy mode, then i went into volumio as (usb) -reflashed Volumio to nvme from the settings, at the end it did say that it failed, but when shutdown, took the usb out, went to bios, nvm0n1 was now there as uefi mode, started it and its now in nvme0n1 Volumio!!
radio music is playing :slight_smile:

log herehttp://logs.volumio.org/volumiobuster/ihBsyQy.html

i did disable dsp, wlan and Bluetooth again, cause i dont use them.

it literally took like 5-6 sec, and volumio is up and running…

startup picture:

It is working, but the data partition does not seem to be resized properly. But that must be because copy-to-disk did not complete.
Do you get graphics output on HDMI?

yes, display is showing the same volumio desktop. Before (not working nvme), if i tried a copy-to-disk within volumio, monitor started to stay black very often. how will data partition get resized properly

ok, im adding one more debug with DAC connected, maybe will be of interest…

also im not familiar with int. radio, yeah sometimes radio fails to play, when next radio station fails, previous played radio also fails or hangs maybe…