Volumio Wireless not working on X86 install

I installed Volumio X86 v2.309 on an usb drive for running Volumio on my old Lenova Yoga 2 but when it loads up the wireless adapter is not available on Volumio.

The option for wireless in network is available in the volumio menu but it does not show SSID in the area or give options for passwords.

If you try to save it an error shows in red

Network restart
Error while restarting network: Error:
Command failed: /usr/bin/sudo
/bin/ip addr flush dev eth0 &&
/usr/bin/sudo /sbin/ifconfig eth 0
down && /usr/bin/sudo /sbin/ifconfig
eth0 up Device “eth0” does not exist

When I go into terminal and use the “ifconfig” command no wlan0 even shows just eth0 and lo

The wireless adapter works in Windows and is Realtek RTL8723AU Wireless LAN 802.11n USB 2.0 Network Adapter.

Does anyone have any ideas to get this to work? I have tried googling for adding Realtek drivers to linux and pi but a number of the commands are not working in terminal on this version. I also modified the /etc/network/interfaces and manually added the my SSID and PSK but that didn’t work either.


Sorry, not much that you can do here.
You could make it work by compiling the driver but it requires some linux skills to do so…
ATM we don’t have plans to include more wifi drivers into Volumio x86

I don’t have a lot of linux skills but I’m really good at following instructions. :smiley:

Can you help me with the google searches so I can attempted to figure this out? I keep running into the issue when looking up information on how to update the drivers that the commands do not work in Volumio’s terminal. Is there a specific version I should be looking up? Specifically, the “make” command is not found, which seems to be pretty common when doing this.

Also, completely not related to wireless but to what I am trying to do. Is there a way to install Volumio to a partition on the internal SSD drive? I tried the instructions here


but when I boot from that, I go to a “grub” menu? I see there is an option to install from the Volumio system menu but that does not allow you to choose a partition. I would like it so I can dual boot the laptop because it will primarily be used for music but I still would like to be able to use it for the odd windows need if necessary.