Volumio will not boot without internet

There have been quite a few posts about issues with Volumio and no internet, but none that I found are quite the same as my problem. I am running Volumio (latest version) on a Rasp. Pi2. It is connected to my router via WiFi and my music is on a NAS. The problem is that if the internet is down (an all too frequent problem lately) Volumio won’t boot - not on my phone with the android app and not from the browser @ volumio/local. Interestingly, if the internet goes down after volumio has booted, it continues to work just fine - even if I have to close the app and reopen it on my phone (another problem I posted separately). I’m guessing this may relate to DHCP vs static IP. I have considered changing to static IP, but I’m not sure how to determine the IP to use. When I open the system tab, it identifies my WiFi as 192.168.2.103, but when I turn Off Automatic IP, it suggests 192.168.1.123 as the IP. I don’t want to screw this up as I think it will prevent ever booting Volumio again unless maybe I attach an ethernet cable which would be a royal pain. A little guidance would be appreciated.
Thanks

That does sound weird.

The DHCP server for your home network is likely to be your wireless router. It mainatins the pool of private network IP addresses and assigns them to requesting devices (such as your phone and your R Pi Volumio.
To properly detrmine the IP range in use for your network, look on your phone (iPhone method follows):
Settings
Wi-Fi - You’ll see your home network SSID and a tick showing that you are connected
Tap on the circled I (Information) symbol
IP Address - This is the IP address assigned to your phone
Router - This is the internal (LAN) IP address of your wireless router
Both will be on the same network range, perhaps 192.168.2.x
The router will typically be on the first assignable IP address 192.168.x.1

This information will tell you which of the two networks you should be using to configure the R Pi Volumio if you want to use a static IP address.

You can log in to your router using the IP address in the address bar of your browser
You can set the range of IP addresses used for DHCP and leave a range at the upper end out for use on devices with static IP configurations
EG. Set 192.168.2.10 to 192.168.2.200 as the DHCP pool scope
Then assign static configuration address from 192.168.2.201 to 192.168.2.253 - (.254 is usually reserved as a gateway/router address).

I am a bit confused. If I set the DHCP range on the router and then set volumio to something above that range, it will connect? Or do I have to tell the router that volumio wants to use that number? What about setting volumio to the number it is currently assigned? I thought that is what I did before, but I’m not sure.
Thanks for the help.

If the connection between your router and provider goes down, then your local network (including DHCP) should still work.
Unless rebooting your router solves the issue, then it probably is a problem inside the router.
I think assigning a static IP will not help in your case.
When it fails, can you connect with other wireless devices to the network. Do they get a ‘lease’ (IP number)?

I’m not sure if I stated the problem incorrectly or if I don’t understand your answer/question. If there is no internet, the LAN still works. If Volumio is connected and running when the internet goes down, it still works and still pulls music from my NAS so clearly the LAN is working. The problem is if I try to start Volumio while the internet is down, it tells me I am not connected to WiFi (but, of course, I AM connected - either on my phone or my main computer and browser. ) The android app says “Not connected to WiFi” the browser using “volumio/local” says it cannot connect. I don’t think I have tried it typing in the IP directly. Next time internet goes down, I’ll try that, but that still won’t help the phone app.

I watched the boot process on my browser (Firefox) and see at one point it is trying to access volumio.com. I am not sure why. ?checking for update? In any event, I bet this is why it won’t boot. It tries to connect to volumio.com, can’t do it, the boot process fails. So why is it trying to connect to volumio.com and can I disable this?
Thanks for any help.

There has been an issue in the past that Volumio stopped working if the internet connection stopped working, but that has apparently been addressed in the current version.

If you have a spare micro SD card, why noy make yourself a Moode installation and try running that with everything the same.
Then you’ll have a good idea if it’s your network and/or hardware that is the issue, or Volumio itself.
Moode is very similar to Volumio (based on the same player I think), it’s a good check to try and narrow down the sourece of a problem.
You write a Moode image to the micro SD card, then boot your R Pi to that instead of the Volumio card.

PS. To answer your earlier question about the static address and your router.
If your subnet mask is 255.255.255.0, then all the IP addresses from 192.168..0 to 192.168..255 are part of the same network.
So if your router is assigning 192.168..10 to 192.168..200 from it’s DHCP pool, the remaining addresses above and below that range are still part of the same network and your router will recognise and route/switch them. Just make sure you put the router’s address as the Gateway address on the manually configured devices. It’s typically 192.168..1 (or in rare (usually Cisco) cases, 192.168..254).