Volumio vs OSMC audio quality (digital environment)

Hi all

I read many good things about Volumio, and I am currently using OSMC. I am trying to go a bit “hifi” (got a yamaha s501 stereo amp, a B&W CM5 pair of speakers, a turntable) but I would still want to continue using the PI as music source.

I wondered a lot about this: would there be any quality difference between OSMC and Volumio when playing music (say .flac) on the same hardware? (RPI 3 + DIGI+ -> optically connected to the AMP). Because I need OSMC for movies etc, and in order to use Volumio I would either need a second RPI or a dual boot configuration, both options having some downsides. For me I would expect that there wouldn’t be an (audible) difference when digital output is used, but I don’t know much about how OSMC and Volumio are doing this.


I don’t know how OSMC treates audio, but we’ve done a lot of audio related optimizations…

Hi michelangelo

In a way this was another question I had as it clarifies (to me) that volumio is not just a distribution making music-listening easier (collections, browser-based,app-controlled, etc) but also dealing with/optimizing the actual music playing process, which most likely is not a priority of the OSMC project. I still don’t know if this would impact noticeably the music quality on the hifiberry digi+ output compared to a vanilla linux generic player, but I guess it’s hard to quantify that. I will keep reading more and give it a try shortly. Thanks.

Frankly speaking, since you use a digi I would be curious too to see if that makes a difference…

If I will compare them I will let you know. In the meantime I have installed volumio, struggled for 2 hours to make it mount a cifs share from my debian NAS, read thousands of posts and tricks and advice etc, and eventually mounted it manually. Afterwards, all went ok and the solution is currently performing just fine, looks quite good I must say!

What was the problem you had with the NAS? We’re trying to get it as easy as possible, yours could be an edge case that would be nice to cover.

Well no matter what I would fill in for my samba share (placed on a debian) it would appear as not mounted. I tried every possible thing, including ntlm options, writing the folder/share in all kinds of formats, using the IP instead of the server samba name, etc. it wouldn’t work. Eventually I just mounted it manually, with NO special options (only the username and pass) and it worked perfectly from there, but I coult not understand why it would not mount if added via the interface. Must note that it would identify the server/share, but it would not mount it after adding it.

Is there any way you could unmount it and try to remount via the UI? After you do that, just paste the relevant output of

sudo journalctl -f

This will help us… thanks