Volumio V2.878 can not boot on a RasperryPi 4 B

Hi guys,

Bought a RasperryPi 4B last week. But Volumio V2.878 can not boot. Green LED keeps solid lit after flashing for around half minutes. No Volumio WIFI AP show on my cell phone. The official Raspberry Pi OS has not problem booting from the same SD card.

I use Etcher flash the image to a SD card. Same SD card has no any problem booting on a RPi Zero or on my RPi 3B.

Any idea about this issue? Could be the RaspberryPi 4B problem or the Volumio bug?
Please help.


This is a community forum, for support specifically with myVolumio, email techsupport at volumio dot org!

I am using this version as we speak on my PI4B…
Can you try reflashing? If it still does not boot maybe (I say maybe) this might mean that we need to upgrade kernel of FW for a higher revision of PI. This already happened before.

I also would double check the PSU. Can you check with another one?

PS: Are you that iancanada?

@ volumio

Yes, I’m Iancanada.

I use both Anker 30W and 60W USB power adapters as power supply, I have no success.
Any other Volumio image do you think I can try?


Welcome here then Ian!

Would it be possible for you to connect a HDMI display and take a picture? That might give us a hint.

We have a beta version with a very recent kernel that you can try:

NOTE: The latter is not a stable version, and its for the buster release on which we are working on.

Thanks, I’ll try it and get back to you then.


Just be sure there are no left-overs from previous image writings and etcher did a succesfull verification.

Open the cmd shell in windows in adm mode.
Enter “DISKPART” and “ENTER”
Enter “LIST DISK” and “ENTER”
Select the correct disk for your SD -card
ENTER “SELECT DISK x” (x=1 or 2 or 3,…) and “ENTER”

Now the SD card is completly empty and ready for burning a new image, without any possible left overs.

Is this RPI4 not booting after update to v. 2.878 the same thing?

New update:
RPi 4B Volumio boot problem fixed.

I confirmed that it’s a bug of Volumio V2.878. HDMI display stuck at the Volumio Logo. Never finish.
There is no any problem after flashing the same SD with the new Volumio V3.066 image.

Thank you so much for the support.


MMMM, but Volumio is meant to be accessed headlessly. So its normal that Volumio logo will stay there.
After you boot 2.878 can you see a network called Volumio ? (volumio hotspot)

Let me know

Can not see Volumio hotspot when boot 2.878.

V3.066 can see Volumio hotspot on my cell phone. No any problem.


Then I fear new revisions of PI4 require some tweaks in the kernel to work properly.
Will get a recent one and so some testing

May or may not be the same thing, but I’ve just tried to update my two Pi’s (a Zero W and an old Pi1) to 2.878 and it’s killed both of them. Neither accessible via wifi at all.

Tried to reflash the zero, and it’s no different - wifi hotspot never shows and trying to connect it to HDMI just gives a black screen.

Trying to reflash again the zero, and roll back the Pi1 to 2.873 that I’ve just seen the link to in the other thread linked above.

try 3.xx if you don’t want my volumio pick 3.10 my favo at then momment
there are some tweaks to get it working… but no my volumio in this one
hdmi needs a plugin touch display plugin would work for that.

I’ve got 2.873 now up and running again, although My Volumio is seeing it as a new device (although the previous version is on the list). Looks like time to set it up again…

Editted to add - the free tier of MyVolumio is now basically gone? A newsletter and nothing else, so 2 devices like it used to be?

Yup, same issue here. Updated two Zero W, both will no longer connect to the Wifi. Reflashed, nothing. Where can I download the previous version?


1 Like