Volumio unresponsive when internet goes out!

Prerequisites

Volumio Information

Volumio Version: v2.873
Hardware: intel i5
DAC: topping e30

Debug Log

Steps to Reproduce

  1. My internet connection went out.
  2. I had been using the Pandora plug in
  3. Even the settings screen won’t display
    …Volumio should definitely work well with local content and no working Internet. This situation does happen…

Additional Information

Yes, Volumio should work locally without an internet connection.

Can you provide further information please. Is this just a one off? Did you try local content?

It would be useful to get a system log when it happens, but if it’s only happened once, and is non-reproducible, then it’s a problem to diagnose.

I suspect it is easily reproducible. The only question in my mind is if the Pandora plug in was a contributing factor. I left it undisturbed and then verified it recovered when my Internet returned. It did.

Forgot to answer one question… Yes, I tried to get to local content. I could not. As I said, even the settings screen showed “blank.” This seems like a serious bug. That’s why I logged it.

If you suspect the Pandora plugin then remove it (plugins can and do have unforseen consequences), and run the device on some other content until you are happy that the problem has gone. If you do still get the unresponsive situation, then you can rule out Pandora and still get a system log to investigate what is happening. If at all possible note the time that the problem occurs so it can be pinpointed in the log.

I’m trying to work out a different problem with dsd files.
I sent the log in… this should also hopefully have the Internet weirdness time period.

http://logs.volumio.org/volumio/jbyIVX0.html

I can’t see anything in that (very big) log file about loss of internet connections. Plenty of complaints about your DAC and a mixer control … these could be sufficient to make Volumio unresponsive??

I think I’d still remove the Pandora plugin as part of your problem solving, including for the DAC. It leaves you with a much simpler system, and fewer system logs to sift through.

Also, if you are intending to send a log, please do a reboot just before your problem-solving session.

Actually, I did see some errors from the Pandora plugin that seemed related to it losing Internet in there.
If the problem is the Pandora plugin, can the person who maintains that be notified?
The log is quite large because it also happens to contain reloads of the music index. If those are removed, it’s much more manageable.
I sent it originally for a different bug which does relate to the DAC and DSD playback.

Sure, but we are still waiting for your confirmation that the Pandora plugin is causing your problem.