Volumio to Play from iTunes on Mac

I am running Volumio on a Raspberry Pi and iTunes on a Mac, both on the same network. How do I get Volumio to play what I have stored in iTunes? Thanks.

How do I get Volumio to play what I have stored in iTunes?

What is your desired usage pattern?

Do you want to “drive” from the Mac and use Volumio as the speaker output?

You could do this by using AirPlay from the Mac to Volumio. That way anything you play in iTunes will play from the Volumio output.

Do you want to “drive” from the Volumio UI and just use your Mac as a place to store your music?

In this case you’ll need to share your Mac’s music folder https://support.apple.com/en-gb/guide/mac-help/mh17131/mac. You can then connect to this share from your Volumio device and play the audio.

Thanks for the quick reply. I want to “drive” from Volumio to play the music stored on my Mac.

Having shared the Music (and iTunes) folders on the Mac, how specifically do I connect to it from Volumio?

When I go to Settings > Sources, under Network Drives, when I click on the “+ Add New Drive” button it says, “No Network Drives Found.” Do I first have to fill in the fields for Alias, NAS IP Address (this at least I know) and Path/Network share name or subfolder path? Alias seemingly could be any name. But what about the Path field?

When I try “MB_Mac” “10.0.0.1” and "Macintosh HD/Users/mbouquet/Music and Save it shows up with a red X under Mounted and a size of 14.62 MB.

Thanks.

Please do a log via http://volumio.local/dev immediately after trying to connect, enter a meaningful text and then press ‘Send’.
Volumio will return a URL which you should post here for us to have a look.

Thanks. I got this URL after doing Save trying to add my Mac as Settings > Sources

http://logs.volumio.org/volumio/hRrTydN.html

Alias seemingly could be any name. But what about the Path field?

When I try “MB_Mac” “10.0.0.1” and "Macintosh HD/Users/mbouquet/Music and Save it shows up with a red X under Mounted and a size of 14.62 MB.

Did you try using the name of the folder rather than the full path? Also, did you try checking the advanced configuration and adding a username/password? The user that you use will need access to the shared folder and files.

Unfortunately no success yet.

I’m sharing both my Music and iTunes folders in the Mac’s Sharing > File Sharing Preferences Panel, with a named user having both Read Only and Read/Write privileges (I tried both). I also set up Media Sharing, with the Library Name “Owners_Music”, allowing guests without requiring a password.

I’ve tried using just the folder name, resulting in the paths “\10.0.0.10\Music”, “\10.0.0.10\iTunes”, and “\10.0.0.10\Owners_Music” along with the designated Mac user’s name and password. The drive shows up with a 15.09 MB size but Mounted: X . UPNP Renderer, Shairport-Sync, and DLNA Browser show up as On and Active.

In most situations you would need to use double backslash in the first position. For example \10.0.0.2\sharename\Subfolder Subfolder is only used If you want to make your mount point on a different folder.

Have you tried to connect from an other device? Pc, Mac, windows, Linux? Did that work?

My path already showed a double backslash but showed an X in the “mounted” column. When I tried editing and added a double backslash in the NAS IP Address field (which previously just had the IP address) I got an error message: "Error when adding network drive…. ‘//\10.0.0.10/Music’’/mnt/NAS/MJ-iMac’ mount.cifs: bad UNC (//\10.0.0.10/Music)

You could try setting it from the command line, easiest way would to enable ssh via the /dev page. You should be able to quickly find the commands online.