Volumio testing on Virtualbox no UI


I’m new to Volumio, and I was trying to set up VirtualBox with a Volumio 2 image I downloaded yesterday from Github.

Well, everything was working as expected, the image is booting, I can ping and ssh the Volumio virtual machine.

But there is no UI when I enter the IP of the Volumio machine in my browsers address bar.

When using “top” or “ps -x”, there is no msd process, so I think the msd is not running. Are there any log files I could examine to see what the problem really is about?

Any help is appreciated, thanks for helping a newbie out of trouble…


Did you follow the Preliminary Setup steps as described on github?

In /volumio type git pull npm install killall node && node index.js

Uh. No… just downloaded it yesterday and did close the browser window… stupid me!

npm install throws a lot of errors… I try to follow the complete instructions on github, if I fail, I’ll be back…

OK, so I followed the instructions… I had a little problem with this one:

sudo apt-get install libavahi-compat-libdnssd-dev

but after

sudo apt-get update

this line worked too.

But - still no UI… tried port 80 and 3000. Samba is working.

node index.js

throws an Error (see image)

Any ideas?
Screenshot 2015-12-16 10.37.45.png