Volumio Spotify Connect2 change sample rate

Hey there fellow volumios,

because i recently got my hands on a spotify account i wanted to use the Connect2 plugin.
Everything works fine in terms of connection and actually streaming the content to volumio.

In my setup where a Pi4 is connected to speakers via usb the sample rate of 44.1kHz that is used by the plugin / sent by spotify are not supported with those speakers. I need a sample rate of 48kHz otherwise no sound is audible whatsoever.

So my question is: Is there any way to change the sample rate for the plugin or any other way to force my output to 48kHz? Sadly all plugins bypass the volumio internal resample mechanism…

Thx for any help or suggestions


Hi SCMA, welcome to Volumio. :slight_smile:

Interesting question, because I assumed that Spotify Connect would be subject to resampling settings in the Volumio UI.

I suspect that the answer is no, but the plugin authors might like to clear up the issue @Balbuze @ashthespy

It is weird as the Alsa pipeline provide a plug supposed to convert data to what is supported by HW…
At this point, an easy way is to use FusionDsp that allo to resample all sources…
Edit what is volumio version you use?

Hello again and thank you for replying to this!

volumio version: 3.179

All i can say so far is, that as long as i set a bitrate of 48kHz or higher my speakers do their job.
Anything below just stays silent. Was not able to find out what sample rates the connection via usb on those speakers supports.

I’ll give FusionDsp a shot.

Thx again!

No, cause it doesn’t use MPD, but a custom daemon… It has a rather basic alsa implantation, that served my basic needs. It could be rewritten, but need to make time to do it.

You could also try editing the daemons launch script and add LIBRESPOT_RATE_RESAMPLE=1

Or just run a test with

cd /data/plugins/music_service/volspotconnect2/
LIBRESPOT_RATE_RESAMPLE=1 vollibrespot -c volspotify.toml