Volumio running CD drive at noisy high speed

I am using an HP USB CD/DVD Drive (F2B56AA). Volumio is running the drive at high speed (up to 24x for this drive), and the drive is very noisy as it is constantly spinning up and spinning down while playing a CD.

When I connect the same drive to my Mac or PC and play a CD with VLC or Apple Music, the drive is almost silent.

I am running the latest version of Volumio 3.

Same with me. Upgraded to volumio3 / premium to have this feature. I bought a lite-on Es1 which was reported to be a) silent during playback and b) running with a raspberry pi. Both is true. a) while hearing music on any windows PC and obviously b) but together I have the same symptoms which metro reports. Additionally there is this typical CD-ROM noise when one track ends and the next is beginning. This happens not on the PC. Is there any chance to have a silent playback?

Thank you in advance and cheers

Arnd

…and of course gapless playback would also be nice. Somebody suggested this feature longer ago and Michelangelo responded that this would be no great deal. So I´m waiting patiently…

My Volumio RPi is on my desk and the CD drive noise makes it unusable. I can change to a different drive and I’d like to ask @volumio which drive models you have tested that run quietly. I’m also willing to ship my drive to one of your developers for testing.

The topic was brought up before, with no resolution:

After some googling and finding the magic words “cd drive speed” got some hot hints even in this forum

so I tested it with great success on my cd drive. The audible difference between different speeds (I testet 1, 2, 4, the number behind the -x) and the time from the drive starting spinning until you hear music is hardly noticeble if there is one at all. So if something should be fairly trivial like gapless playback claimed here: Does Volumio 3 support gapless CD playback? - #2 by volumio
it would be the implementation of such a feature as an option for playback, if the claimed automatic here: Cd player speed issue - #2 by volumio
is not successfull

@volumio many thanks in advance! :innocent: :zipper_mouth_face: :stuck_out_tongue_winking_eye:

Cheers from Bavaria

Arnd

EDIT: since the carriage return in citing doesnt work: the magic command is:

eject -x 2 (or 1 or 4) /dev/cdrom

You don’t have to get eject beforehand, it is on the machine already

EDIT2: Unfortunately you have to repeat the command every time after a new CD inserted, because the ejection of the CD resets the setting (the commands name is “eject” after all :man_facepalming:). So an integration in the web interface would be REALLY appreciated. :pray:

Thanks, I was able to get a lower speed with the “eject -x 2 cdrom” command. However as you said, between tracks there is a big gap and noise from the CD mechanism. I think it loads one track at a time and re-seeks before starting the next track. When I tried to play an entire CD, it played most of the way but got stuck, and I couldn’t get it to recover even after ejecting and reloading the disc. Then I switched to Qobuz and couldn’t get it to play either, and finally I had to reboot Volumio. I feel that CD playback is very unreliable and not usable.

So to sum this up @volumio : I clearly do not like to, but I feel the need to remind you that this is a premium feature and we are paying for this. In my case this was the key feature for a premium upgrade (apart from multiroom playback, which is quite nice but I could do without).

If found some workaround here:

Which was tricky to get to work.

This may be old fashioned, but sometimes I´m standing in front of my CD collection and let the inspiration “what next?” come from these shelves. Then I´m not always in the mood to turn on the PC and wait half an hour until the CD is ripped to have a silent & gapless experience.

“So pretty please, with sugar on top” do the “fairly trivial” work. :pray:

No offense & cheers

Arnd

1 Like

Actually, I have to thank you for this.
This command was already sent in Volumio, but I missed the fact that you have to send it everytime the CD is openned\closed, otherwise the setting is discarded.

Thanks for this hint, I feel I should have suspected it :wink: Will be added on next release

1 Like

Hi Michelangelo,

Many thanks for that one, but: I quoted you already (in the very same post), that the “automatic” detection of the lowest speed available fails sometimes (so obviously even for the first CD in my drive). Typing in the eject command seems to force something that isn’t detected by your automatic. Do you use it or something like hdparm ? A settings option to force the silent operation would be very useful in those cases.

And again: Implementation of a gapless playback is still lacking and extremely necessary for listening to something like Pink Floyd - The Wall, which should be enjoyed as whole. The gaps actually produced feel like eternity.

As @metro mentionend (by the way - where did his last post go? He mentioned a competitor. Did you remove it?) there are solutions for a silent and gapless playback. I heard of a linux software which is named after a synonym of daring (:stuck_out_tongue_winking_eye: :grimacing:). I worry about that your implementation of CD playback works completely different to the mentioned solutions, so that the goals are not so easily achieved.

Anyway keep it up and thanks in advance for your effort.

Cheers

Arnd

Yes, I shouldn’t have named the competitor and I would like to apologize.

Hi Michelangelo @volumio ,

I would like to kindly remind you, because it was definitely not added to the next release (3.324, which I am running now, system info beyond). Also gapless playback still missing.

raspi 4B+ 4G with audiophonics AES/EBU HAT (hifiberry digi driver)

Many thanks in advance

Cheers

Arnd

EDIT: Mentioned it in an older post above, but to complete system information: DVD-ROM: Lite-On ES1

1 Like