Volumio refuses to scan usb stick (due to missing partition table)

E2: It seems the stick contains no proper partition table -.-

Title pretty much sums it up, i can see one usb device within the music-library, but it shows up as empty one.(Windows Pc have no proplem in showing and playing the content from the stick)

Stick →

  • Fat32
  • 4x root level folders
    – music files directly within these folders

Pi 4, 3.182 (Also older versions seems to behave same with this stick)

E: Stick in question is this one, without any modifications made to it → EMMA Webshop - EMMA Competition USB Stick 2022 limited edition
So no, im not going to modify it in anyway, because that might mean i cannot use it in competition, would rather want to know why volumio does not scan it, and since my knowledge in linux area is quite limited, would like to have some help investigating why this happens.

We already had a report of this a week ago.
Volumio 3 relies on udev actions, where it expects a partition “add” action from the kernel to mount the device.
However, when there are no partitions on the disk, this never happens.
Ubuntu and Debian show the same behavior.
So, currently there is no automount possible without a partition table.

Is there any workarounds for such cases? i can allready see this being a PITA for me when the competition season starts, if they make us use “official media” which the judges bring with them?

What do you mean with “competition season”?
Edit: ok, got it.

No workaround at the moment, the automount code in the networkfs plugin would have to be modified for this, don’t know whether this is possible. Further analysis would be necessary.

I contest in car sq competitions, rpi4 with volumio being the media source in my car.

What i mean if the judges in there will have these sticks with them and volumio refuses to read the content of those I’m screwed sadly.

Well, i have 5 months time to figure how to make it mount automatically, regardless of partition being in there or not.

I’ll help with that, when it is possible to allow such disk structures, others would benefit as well. Bumped into the issue myself before, but reformatted the disk to solve it. That was before I found out last week what the issue was.

KERNEL[5391.371530] add      /devices/platform/scb/fd500000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0/usb1/1-1/1-1.1 (usb)
KERNEL[5391.374267] add      /devices/platform/scb/fd500000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0/usb1/1-1/1-1.1/1-1.1:1.0 (usb)
KERNEL[5391.374904] add      /devices/platform/scb/fd500000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0/usb1/1-1/1-1.1/1-1.1:1.0/host1 (scsi)
KERNEL[5391.374967] add      /devices/platform/scb/fd500000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0/usb1/1-1/1-1.1/1-1.1:1.0/host1/scsi_host/host1 (scsi_host)
KERNEL[5391.375045] bind     /devices/platform/scb/fd500000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0/usb1/1-1/1-1.1/1-1.1:1.0 (usb)
KERNEL[5391.375152] bind     /devices/platform/scb/fd500000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0/usb1/1-1/1-1.1 (usb)
UDEV  [5391.383787] add      /devices/platform/scb/fd500000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0/usb1/1-1/1-1.1 (usb)
UDEV  [5391.386925] add      /devices/platform/scb/fd500000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0/usb1/1-1/1-1.1/1-1.1:1.0 (usb)
UDEV  [5391.389393] add      /devices/platform/scb/fd500000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0/usb1/1-1/1-1.1/1-1.1:1.0/host1 (scsi)
UDEV  [5391.392312] add      /devices/platform/scb/fd500000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0/usb1/1-1/1-1.1/1-1.1:1.0/host1/scsi_host/host1 (scsi_host)
UDEV  [5391.393761] bind     /devices/platform/scb/fd500000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0/usb1/1-1/1-1.1/1-1.1:1.0 (usb)
UDEV  [5391.396064] bind     /devices/platform/scb/fd500000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0/usb1/1-1/1-1.1 (usb)
KERNEL[5392.390706] add      /devices/platform/scb/fd500000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0/usb1/1-1/1-1.1/1-1.1:1.0/host1/target1:0:0 (scsi)
KERNEL[5392.390791] add      /devices/platform/scb/fd500000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0/usb1/1-1/1-1.1/1-1.1:1.0/host1/target1:0:0/1:0:0:0 (scsi)
KERNEL[5392.390845] add      /devices/platform/scb/fd500000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0/usb1/1-1/1-1.1/1-1.1:1.0/host1/target1:0:0/1:0:0:0/scsi_device/1:0:0:0 (scsi_device)
KERNEL[5392.390969] add      /devices/platform/scb/fd500000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0/usb1/1-1/1-1.1/1-1.1:1.0/host1/target1:0:0/1:0:0:0/scsi_disk/1:0:0:0 (scsi_disk)
KERNEL[5392.391048] add      /devices/platform/scb/fd500000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0/usb1/1-1/1-1.1/1-1.1:1.0/host1/target1:0:0/1:0:0:0/scsi_generic/sg1 (scsi_generic)
KERNEL[5392.393139] add      /devices/platform/scb/fd500000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0/usb1/1-1/1-1.1/1-1.1:1.0/host1/target1:0:0/1:0:0:0/bsg/1:0:0:0 (bsg)
UDEV  [5392.394951] add      /devices/platform/scb/fd500000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0/usb1/1-1/1-1.1/1-1.1:1.0/host1/target1:0:0 (scsi)
UDEV  [5392.398693] add      /devices/platform/scb/fd500000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0/usb1/1-1/1-1.1/1-1.1:1.0/host1/target1:0:0/1:0:0:0 (scsi)
UDEV  [5392.403185] add      /devices/platform/scb/fd500000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0/usb1/1-1/1-1.1/1-1.1:1.0/host1/target1:0:0/1:0:0:0/scsi_device/1:0:0:0 (scsi_device)
UDEV  [5392.405548] add      /devices/platform/scb/fd500000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0/usb1/1-1/1-1.1/1-1.1:1.0/host1/target1:0:0/1:0:0:0/scsi_disk/1:0:0:0 (scsi_disk)
UDEV  [5392.408998] add      /devices/platform/scb/fd500000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0/usb1/1-1/1-1.1/1-1.1:1.0/host1/target1:0:0/1:0:0:0/bsg/1:0:0:0 (bsg)
UDEV  [5392.411272] add      /devices/platform/scb/fd500000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0/usb1/1-1/1-1.1/1-1.1:1.0/host1/target1:0:0/1:0:0:0/scsi_generic/sg1 (scsi_generic)
KERNEL[5392.460347] add      /devices/virtual/bdi/8:16 (bdi)
UDEV  [5392.461906] add      /devices/virtual/bdi/8:16 (bdi)
KERNEL[5392.462530] add      /devices/platform/scb/fd500000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0/usb1/1-1/1-1.1/1-1.1:1.0/host1/target1:0:0/1:0:0:0/block/sdb (block)
KERNEL[5392.464182] bind     /devices/platform/scb/fd500000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0/usb1/1-1/1-1.1/1-1.1:1.0/host1/target1:0:0/1:0:0:0 (scsi)
UDEV  [5392.537934] add      /devices/platform/scb/fd500000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0/usb1/1-1/1-1.1/1-1.1:1.0/host1/target1:0:0/1:0:0:0/block/sdb (block)
UDEV  [5392.541282] bind     /devices/platform/scb/fd500000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0/usb1/1-1/1-1.1/1-1.1:1.0/host1/target1:0:0/1:0:0:0 (scsi)

Not that i at the moment understand anything of it, but this is the log out of “udevadm monitor”, when attaching the said stick to the system.

Yes, correct, but there is no partition add action, which is what Volumio is waiting for.
We’ll take this via PM if you don’t mind, and post here when we have a result. OK?

Sure, was just preparing stick with same data, but proper partition this time. (I guess its handy to have one “not working” lying around unmodified.)

Slightly modified the topic title :wink:

1 Like

Last month I had same problem and solved it by reformatting disk. It was mentioned that Volumio 2 relied on specific debian package for mounting, but Volumio 3 don’t use it because new debian version doesn’t provide it. I forgot to ask, what was name of mentioned package.

Maybe it is good idea for Volumio team to consider providing Volumio’s own version of package in question? If not possible, then try to find working replacement. It may be very disappointing for non-technical new users of Volumio to have these kind of troubles.

Let’s say music lover “X” who wants to get into digital hi-fi playback buys Volumio Primo. He/She knows what is usb hard drive and how to use it. Lets say he/she uses many usb stick in his/her workplace to exchange documents with workmates, but his/her technical knowledge ends there. He/she doesn’t have any further knowledge about partitions and partition tables. He/she knows how to copy files on disk and how to connect disk to Volumio Primo. Due to bad luck he/she has bought good quality disk from good brand, but by default it has partition without partition table. What happens next? Nothing, files are on disk, computer can read them, but Volumio does nothing. After many tries he/she calls to his/her friend and asks for help. His/Her friend maybe uses some other music playing software, still decides to help and offers to visit music lover “X”. His/her friend also bring usb disk with some music. Due to bad luck his/her friend also has disk without partition table. Whats worse his/her friend has a bit more technical knowledge, but still not enough to suspect reason behind problem or how to test and solve it. In this case reading documentation helps very much, if problem is known like it is now, but lack of technical knowledge may make things very bad and can end with some kind of bigger disaster for users. Music lover “X” concludes: Volumio is just piece of junk and starts to use same software what his/her friend uses.

After my own research, I discovered that not having partition table is somewhat unusual but not uncommon. It is more common for block devices with single partition. Block devices are usually tape drives, usb sticks, memory cards and so on. It is technical quirk, but having working workaround for it may be helpful.

1 Like

yes, yours was the topic I was referring to.
There is no workaround, but in case it can be solved and with reasonable effort, then it is an option.

This is what has been done already, it now works the way it does in Debian and Ubuntu distros. They don’t automount disks without a partition table either.

Correct, but mounting such a disk is not the problem.
Expecting an automount for it is a totally different issue.

I’ll support it, but that is not a guarantee.
People seem to think that everything can be done just because they would like to have it.
That’s not how it works, this just is one of the many things to be done. It needs a high enough priority. And that is partly depending on how much demand there is.