Volumio PRIMO: Touch Display issue & Pepper Screensaver Plugin help (please...) :)

Hi,

I’ve tried to install the Pepper_screensaver plugin (awesome looks, it’s the ultimate look & feel that would make me use Volumio for 100% of my music listening experience).

All went well with the installation and configuration of the plugin but, when the timer for screensaver is reached the screen just turns black. With video signal outputted but only a black screen. I only get anything else than black rebooting volumio primo.

Then, someone suggested that I should install also the “Touch Display” plugin. Then I got an error configurating the display:
Captura de ecrã 2022-03-26 175701

After the plugin installed I only get text in image outputted from volumio primo:

Even after rebooting Primo, disabling or uninstalling the “Touch Display” plugin, nothing more than just text. I’ve tooked some screenshots of this (and booting process) - see below.

The only solution is “Factory Reset”…


Always end up with this screen:

Could you help on this?

My main wish is to use the Pepper Screensaver plugin :pray: :pray: :pray:

Any thoughts / help?

Hi pjorgenunes,
I installed Volumio 3.235 in my TinkerBoard; with this board there is no need of Touch Display Plugin and the PeppyMeter plugin seems to fail to work. I think that also in the Primo there is a TinkerBoard.
However I was able to view the vu-meters running via ssh the program volumio_peppymeter.py; after installing the plugin go to:

cd /data/plugins/miscellanea/peppy_screensaver/peppy-meter

then type:

export DISPLAY=:0
sudo python3 volumio_peppymeter.py

This way, if the settings of the plugin are correct you are able to see the vu-meters.
Obviously this is not a solution… but let me know if it works in your case too.!

1 Like

Hi @pdo59,

Many thanks for your input. I was able to test it and, at last, some light at the end of the tunnel (and it wasn’t a train… LOOOL).

I now see the meter (the settings of the plugin - resolution weren’t correct, but I now see vumeter working), still not perfect.

Maybe with this info that you share will it be easier to find an automatic solution for this.

Here it is (the vumeter lights at the top of the screen :slight_smile: ):

there is no automatic solution for the correct size, you need to adapt one of the existing screens to your screen resolution. by adjusting the image to your screen size and edit the meters.txt file to accommodate your screen values.

Yes, but the question with tinkerboard (also the board that Primo uses) is about the screensaver just turns in a black screen if one just installs the plugin.

As stated by @pdo59 only using:
export DISPLAY=:0
sudo python3 volumio_peppymeter.py

in SSH window makes the vumeters come to life.

and that part I don’t get, as this is already part of:
run_peppymeter.sh

#!/bin/bash
cd /data/plugins/miscellanea/peppy_screensaver/peppymeter

if ! pgrep -x "python3" > /dev/null
then
	export DISPLAY=:0
	python3 volumio_peppymeter.py
fi

Indeed it is, this command is taken from run_peppymeter.sh, but I think the plugin maybe doesn’t start this shell script.

No, the shell runs, the problem is elsewhere.

and my 2cts…
Maybe the solution to the problem will be a modification of the userconfig.txt file?
It should be modified and rulers added
IN boot/userconfig.txt:

hdmi_group=2
hdmi_mode=87
hdmi_cvt 1920 1080 60 3 0 0 0
hdmi_drive=2

Unfortunately there is not a config.txt or userconfig.txt file in Volumio 3.0, anyway I created a userconfig.txt file in / boot but no luck.

1 Like

But that was for @pjorgenunes :stuck_out_tongue_winking_eye:
In your photo the vumeter is full

@Gelo5: sorry but I thought you were referring to the plugin which only shows a dark screen.

@pjorgenunes: I have solved my problem and maybe yours too, in the file

/etc/pam.d/sudo

after the first line:

#%PAM-1.0

add this line of text:

auth       sufficient   pam_permit.so

Then in the file:

/data/plugins/miscellanea/peppy_screensaver/peppymeter/run_peppymeter.sh

change the line:

python3 volumio_peppymeter.py

into:

sudo -k python3 volumio_peppymeter.py

with my TinkerBoard this solves the problem.

1 Like

WIth the manual execution of the plugin, I was able yesterday to get the right screen (with the right resolution choosed):

Didn’t have time (yet), to test your solution. I’ll try it today :pray: and I’ll give feedback.

Many thanks for the help. I’m starting to believe I might make it on Primo :slight_smile:

Awesome!!!

Many thans @pdo59 and all that helped on this.

Outstanding!

Glad it works on your Primo too, @pjorgenunes.
But I must tell you that I am not very experienced in PAM, and therefore I do not know if this change affects other aspects of the system, particularly in terms of security. I am investigating.

If you find out just let me (us) know. For now, I just use it with my external HDD to listen to music. :slight_smile:

Hi @pdo59,

I am trying to setup my TBS with PeppyMeter plugin but without type in command manually as:

cd /data/plugins/miscellanea/peppy_screensaver/peppy-meter

then type:

export DISPLAY=:0
sudo python3 volumio_peppymeter.py

The PeppyMeter won’t start even I changed the /etc/pam.d/sudo and run_peppymeter.sh files.

With the first command via ssh, everything is working fine. The PeppyMeter looks as good as on my RPi4. Any hint?

Hi @naimnatnod, I didn’t understand your problem. Can you be more specific?

Hi @pdo59, the PeppyMeter works on my TBS when I manually type in the following on Terminal (Mac):

cd /data/plugins/miscellanea/peppy_screensaver/peppy-meter

then type:

export DISPLAY=:0
sudo python3 volumio_peppymeter.py

I didn’t understand your point of modifying those two files:
/etc/pam.d/sudo
and
/data/plugins/miscellanea/peppy_screensaver/peppymeter/run_peppymeter.sh

I thought these changes would make the TBS starts the PeppyMeter automatically without typing the manual command on step 1.