Volumio on Pi 400, what is wrong with my procedure?

Volumio Information

Volumio Version: 2.917 (and 3.083)
Hardware: Raspberry Pi 400
DAC: iFi Zen DAC V2

Hi all,

Recently I have sold my Volumio Primo to go the Raspberry Pi route. I have a Pi 4 8GB coming and had the idea to already run Volumio from the Pi 400, which is basically identical to the Pi 4.

Could you please follow my steps and tell me where I go wrong…

  1. Fresh download of Volumio 2.917 on the Pi 400.
  2. Write a micro SD card by using the official Raspberry Pi Imager tool. Select the downloaded Volumio ZIP file, choose the target, which is a fresh SanDisk card, inserted in a USB adapter. Press ‘write’ and there it goes.
  3. Shut down the Pi 400, swap the SD card and power up.

Meanwhile I have also connected the USB cable to the Zen DAC, which is also separately powered.

What I would expect, after 10 minutes of waiting, is the Volumio WiFi host network showing up. But no network shows up… Wiring the Pi 400 does not help either.

Then I connected a screen and could login via volumio/volumio.

This results in the Pi (Volumio) being visible in my wired network. But still no wireless host network.

Than I can select the Zen V2 as the output device, but the unit itself stays silent. I have tried both variable and fixed RCA outputs. There is simply no sound (and volume to 100).

When I select the HDMI as the audio output device, I have sound coming out of my monitor (from my Qubuz subscription).

So that seems to work. But still no WiFi.

I have read more than once that you do not have to login Volumio (in the terminal window) to make it work. Just start up the (headless) unit and it’s fine (and ignore the login which you don’t see anyway when you use the unit headless.

With the Primo, the HDMI output mirrors the picture from the control device. Now with the Pi, there is a always a terminal window.

Next step was to try the latest Volumio 3 beta, but it does not seem to make a difference

What have I done wrong?

(except selling the excellent Primo)

Thanks for your advice.


Honestly, the PI400 is not officially supported, and never tried it, so can’t really be helpful…
I guess the USB ports on the PI400 are not compatible with DACs somehow?

Thank you.
I am serious about the Primo though :relaxed:.

Today I will get a Pi 4 so I can check. Although the 400 represents itself as a 4 as well. AFAIK it is exactly the same, apart from the layout (and using the last 2711 generation).

What puzzles me is that no Volumio network pops up after a fresh (and headless) startup.

All 400’s use the latest revision (C0 stepping) of the 2711 SoC.

Could that be of influence?

The Pi 4 coming today also has the new C0 stepping, so I am curious…

Now I know what was wrong with my procedure…I was simply writing the image to the SD card too soon, so even before it was (fully) extracted.

Volumio 3.135 is running great now. Although once in a while the music (from Qobuz) suddenly seems to stop without reason.

This thread can be closed I think. Thank you for your help!