Volumio on ODROID HC1/2

I think running Volumio on an ODROID HC1 with an SSD would make for a perfect and silent MEDIA center that can be used for both Audio (USB to external DAC) and Video (SAMBA).

Has anyone tried to make Volumio work on an ODROID HC1/2?

I don’t have an answer, but you might be interested in this thread.

The thread @chsims1 is referring to lists an older, “unsupported” version for the XU4, which should be bootable on an HC1 or HC2.
Likely only from eMMC at the moment (SD needs a small fix), just try it.

When it works, put in a request for an update in that thread, so it does not go lost.
Please follow up there.
I will update to version > 2.513 and also add a fix, allowing it to boot from SD.
It may take a couple of weeks, depending on what else needs to be done for other boards…

Sackstarch! Luege mal…

So it turns out the HC1/2 does not have an emmc module and the currently linked version for the XU4 (from the above link) does appear to boot from microSD, but I cannot access the web interface or connect by SSH.

So it does boot?
You need to go to the dev page and enable SSH (or drop a file calle “ssh” into the boot folder).
Did you try that?

I expect it does not boot properly, the emmc/sd issue…

could you try to change the boot.ini from

setenv bootvolumio "imgpart=/dev/mmcblk0p2 imgfile=/volumio_current.sqsh console=tty1 console=ttySAC2,115200n8 rootwait ro fsck.repair=yes"


setenv bootvolumio "imgpart=/dev/mmcblk1p2 imgfile=/volumio_current.sqsh console=tty1 console=ttySAC2,115200n8 rootwait ro fsck.repair=yes"

I have a fix for that, but has not been implemented yet, next version coming soon.

So I modified the boot.ini as you recommended. The system appears to boot as I can ping it. Connection over SSH is refused however despite putting the empty file named SSH into the boot folder.

Note that it has to be “ssh” (it is case-sensitive)
As you can ping it, the network is up, so the system must be past the init stage.
There is no GUI when using a web browser on “http://”?

I tried both SSH and ssh, neither dit work and I am also not able to connect using a browser.

i can’t follow up until next week, but will have a look at this issue. You don’t happen to have a usb-ttl adapter, do you?

Unfortunately I don’t. Many thanks for trying to make this work!

OK, a new version is available now and solves the issue wih booting from SD and eMMC with the same image.
With booting from SD, it supports HC1/HC2 as well.


  • Added myVolumio support
  • New kernel 4.14.y with updated support for DSD-direct (native) capable USB Audio devices
  • Supports booting from SD and eMMC

I can confirm the build works on an HC2. That’s great! Many thanks!

Which USB Soundcard would be recommended to to be plug&play, nice price and audiophil?