Volumio on a Odroid C2. Volume/settings issue?

The volume on this can’t be adjusted in the webui. If I go into settings and set the mixer to software after that the whole thing stops functioning. Until I reboot Volumio is unresponsive, meaning the webui has a circle in the center that rotates (if you will). If I reboot, the settings are back to “non” for mixer. Trying again results in the same issue.

Aside from that it sounds OK when played with “out of the box” settings, albeit with much a higher volume which made me want to figure out how to reduce the volume without having to reduce the volume on the stereo.

One other comment. I don’t get Volumio. It plays music from my library or some other source. I thought it had a Sonos like feature where I could play the same song on multiple devices that are running Volumio also. Is this the case? I didn’t find it featured in the interface.

  • There is no Sonos-like functionality and Volumio has never been advertised that way, but who knows for the future? Lots of things are happening and interest in multiroom is certainly there.
    Something a little like Sonos is the snapcast plugin. I must admit, never tried it myself on on a C2 or any other sbc. Configuration is said to be a little tricky, but people use it.
  • As for the playing music, the Hifi Shield 2 has hw volume control and works fine.
    The “simple” HiFi Shield and Shield+ don’t have it, so we can only control that with software control, which is not a good thing to do as it negative impact on the music quality (bit perfect goes lost). Unfortunately sw volume control on C1/C2 has been broken for a while and there is no solution yet, still on the TODO list.

thank you my issue has been solved