Volumio not scanning music library entirerly

Hi, I have volumio 2.0 installed on a raspberry pi 3 and my music in a 1TB usb drive attached.
The problem I m having is that every time I scan the music library I get a different number of album, artists and tracks. There are always some missing.
The update library option doesn’t seem to work. I have tried to reboot the pi and the hard drive but I get the same result.
Has anybody had a similar problem or knows how to fix it?

install minidlna latest and you don’t have this problem.

We have solved hopefully this issue in latest version, it will be available in few weeks.

The suggestion about minidlna is not relevant at all

We have solved hopefully this issue in latest version, it will be available in few weeks.

The suggestion about minidlna is not relevant at all

I am also having this issue with scanning my usb drive. Thank you Michaelangelo for your work. I love this program!

If you guys want to try it:
updates.volumio.org/pi/volumio/2 … pi.img.zip

In case it still fails, go to playback options and enable extended format support and rescan, let me know

I am using the latest version 2.246 and i also face the same issue. Every now and than my music library gets wiped out. Also while updating the database if volumio is shutdown/restarted, it losses all the progress and in next restart it show same old indexed status. its really frustrating that there is no fix so far for this issue and it takes good 7+Hrs to scan a library of approx 60K every time to rebuild the music database index.

I have two RPi 3-B, one with the Allo Boss board and another with Allo DigiOne, recently acquired. At the moment I have two problems.

Until version 2.224 (intermediate), my disk was easily and correctly mounted. In later versions, Volumio does not mount the disk (it’s a hard drive on my computer, exclusively with music files).
I have tried versions 2.245, 2.246 and even 2.279, suggested by Michelangelo in a topic above, without success.
So I’m using version 2.175 for Allo Boss, since it is more stable than 2.224.

To use Allo DigiOne, I tried running 2.224, which is the first with the driver for this card. This version, despite mounting the disc correctly, can not make DigiOne work. When you try to play a song (or album), the following error message appears:
“Failed to open “alsa” [alsa]; failed to open ALSA device “hw:1.0”; No such file or directory”.
Later versions of 2,224, as I said above, do not mount the disk. So I do not know if they would have the same problem with DigiOne.

I would appreciate it if anyone could help me solve these two problems.

Thank you.

P.S .: Sorry for my English. I am not fluent in that language.

Tried 2.279. It stops scanning at somepoint (approx at 39441 files) and whatever do it doesn’t progress further. Tried update, rescan but buttons doesn’t trigger anything. Also tried to reset to default, and delete user data but these button also does not seems to be functioning.

Perhaps is the solution here:

I don’t know if anyone is still having this particular issue or if my solution will help but here goes;

You might want to check inside the folders that your music files are stored in on your external drive. If there is another folder with album extras (images, pdf’s, etc.) or a zip file in the same folder as your music files either place them in a folder outside where your music files or delete them if you don’t feel you need them.

The problem I had was with a couple of folders appearing but no music files appearing inside of them. I noticed each folder had a zip file inside of it. I shutdown my Pi, plugged my external drive into my laptop, and either deleted the zip files or stored them somewhere else. When I plugged the drive back into my Pi, booted back up, and my music files appeared.

Everytime I go to listen to a particular album in a folder and I don’t see the music files in looking for this is usually reason if they do not appear.

I tend to back up zip files of the albums I purchase from Bandcamp when they are digital copies.

Hopefully this might be another solution for anyone else who might still have trouble with this particular issue.