Volumio not load background when use NetBIOS


I run volumio on a raspberry pi 3B and I have installed winbind in volumio to make it accesible from windows pcs using NetBIOS. I configure it properly and I can access the volumio web GUI from windows pc using its Workgroup name, all works perfect but the background and miniatures are not loading…

When I access the web using IP all images are there.

Any idea of what causes this problem??

Pd. Thanks for the help and sorry for my bad english!!

Really hard to say, probably a CORS problem … Sorry but don’t know how to help

Okay, thanks for the quieck reply. I will continue investigating if I find something I will post it :slight_smile:

I have solved the problem, I have edited the /volumio/http/index.js code adding a basic-auth function to ask for user and password to enter the volumio UI (in order to protect the UI from neighbours) and have forgotten to add “app.use(’/dev’,name-of-function);” to the code.

I really don’t know how it works because of my bad nodejs knowledge but it works.