Volumio network player

I have built a new network player and internet radio to replace my old reciva goodman radios.
I have had some problems but now have a good working system which has taken me two weeks in the evenings but has been well worth it.
I will go through my experience to save others wasting time on trivial matters.

This is my main network player with an integrated amp

List of components

  • Temporary wooden project box
  • Raspberry pi rev 1
  • 5V, 2A plug transformer, internal circuit only.
  • USB DAC board PCM2706/CS4398 from Ebay (same as shown here maydaydiy.wordpress.com/maydus-p … 8-usb-dac/)
  • Transformer 240 to 2 x12v, 1 amp to power the DAC
  • TDA2030A Audio Amplifier Amp board DIY Components kit SZSP06. 2x15W output
  • MCFE030/09 Multicomp Transformer , 30Va , 2 X 9V to power the amplifier.
  • Wharfdale diamond 9.0 speakers.
  • Pi Supply Switch from Mod my pi as an ATX style power switch (attached to GPIO 7 and 8)
    *5V relay circuit to switch amp and DAC. (attached to GPIO 5V, Ground and originally GPIO 17 but now another Ground)
    *TP-link TL-WN722N usb wifi dongle
  • 20x4 LCD matrix display (attached to GPIO 5V, Ground, 18,14,23,24,25,22,21(27)
    future addition four push buttons for play/pause, stop, skip back, skip forward.

Summary of building and getting up and running.
Raspberry Pi, DAC, amp and speakers connected together.
install Volumio to SD card Beta 1.1
Run initially with LAN. Add wifi SSID and password. shutdown and remove LAN
Now running with WIFI. Plays radio music.

FIrst problem as I was using a rev 1 raspberry pi. The pi stopped due the current draw from WIFI dongle.
this was solved by soldering bypass wires across the USB fuses F1 and F2. This is not a problem on Rev 2 boards as these fuses have been removed.

Adding music server FLAC music files.
using NFS.
This works fine, however the/etc mpd.conf file needs ffmpeg changing to no.
decoder {
plugin “ffmpeg”
enabled “no”
This always changes back to “yes” when settings are updated from the UI. Is there a way to change defaults to no?