Volumio, NAS server, WebUI and everything else...

if there’s any life out there hear my voice calling out loud, please. Frustration is over the roof already.
This is my first ever post here.

I’ve decided to give Volumio a try. Sounds like a great alternative to any other (expensive) music/control systems I, as a profession, program and install (Crestron, , URC, Sonos…) but honestly it’s still a long (and promising) way to go!

As the Rules state, I introduce myself as a guy that’s always attracted by these types of gizmos (robotics, electronics, programming… ) and recently I’ve found the endless possibilities to create PI projects. I’m so excited that I can’t stop sharing and showing my kids that sky’s the limit when you have a passion for something you love. Meanwhile I’m a fanatic audiophile! love music dearly. THE BEST sound or nothing.

So, in this regard,I’ve purchased an IQaudio DAC as an add-on to my RPI B+. Super product that does what is supposed to.
In addition I’m using a Buffalo NAS Linkstation server where my music folder resides;
new micro-SD card (32Gb) with Volumio image (got the image from volumio web site and even tried the one from iqaudio.com/downloads as well)

The problems:

  • Through Volumio, I’ve set my unit with a static IP address; All good so far, I’ve rebooted and I can access the unit either through a browser or SSH;
  • No video signal through RPI’s HDMI output so the only way to access the command line is through SSH so far;
  • Now, often (several times) Volumio starts spinning “Connecting” and got stuck on this state every time I’m trying to select different options from Menu (System, Network, LIbrary…). Got to reboot and try again, frustrated.
  • Volumio gives me error when mounting my NAS (windows share) server as follows:

Last system mount error
mount error(13): Permission denied Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

path is correct (IP address, folder, user & psw), NAS works fine, accessible from any other remote location. After I’ve added the NAS mount I left it ON all night to give time for indexing database. This morning found the error message above; any idea?

  • the only thing that’s working (when it’s working) is Webradio. I’ve tried to add 3 stations, added the correct URLs but Volumio doesn’t want to play them.

  • another question for you, what exactly should I update here as I’ve read many Posts saying that after updating firmware, Volumio got mixed up and needed a fresh re-install;
    right after installing Volumio I did:
    sudo apt-get update
    sudo rpi-update

  • what about the dist-upgrade?

  • So, definitely I’m missing something I can’t fix on my own but that’s why you are here. To share your knowledge, experience and help.
    If it wasn’t for the great spirit of community, helping each other, perhaps I won’t be posting here. I really do believe that! I hate it when I’ve read Posts where people confirmed that they’re problems were fixed but don’t post the answer/solution so others might benefit down the road…

anyway, any suggestions are greatly appreciated guys and thanks for your time!


“A clever person solves a problem. A wise person avoids it.”


Hi TangoRom,

imho is it better to use NFS instead of Samba. Even when you want avoid problems :wink:

I would you suggest to install NFS on your Buffolo LinkStation:



Thx Klauss for your quick reply.

My NAS server is windows based share. Therfore I use Volumio with SMB/CIFS fileshare protocol. NFS is mostly used for UNIX file type of sharing. As I mentioned, I can access my NAS from any other machines (linux or windows based) within the same LAN with no problem. Is the Volumio which drives me crazy as I cannot add any type of share to my Library. (I’ve tried to add a local folder from a windows machine at no success). Kind of exhausted all options I could think of. I’m open to any suggestions/advice.

thank you.


hi tangorom,
download and install last firmware version (1.7) and Raspi/volumio mount Linkstation without any problem…