Volumio hotspot, how connect?

hi all,
I would like to use my Raspberry zero as standalone and portable music player so I installed last release(0.979) of Volumio because I read that Volumio creates an open hotspot by default if not connected to any wireless network. Great, this is exactly what I want! If I connect to web GUI, in the network tab, I really see that an hotpost is active on address 192.168.211.1, but I’m not able to connect? I dont see any available wifi network, is the SSID broadcasted or it’s required a manual configuration? It’s possible that my wireless adapter is not compatible (I think no, in the network tab I see the list o available wifi network)? My wireless USB Adapter is TP-Link TL-WN725N v.2
Thanks

If you don’t see a wireless network, your wifi adapter is not able to create it .
I suggest you to use this :
us.edimax.com/edimax/merchandise … ew-7811un/

:frowning:
then you confirm me that, without any configuration changes, the SSID should be visible and working?
that is strange because, before read about Volumio hotspot feature, I tried this procedure: raspberry-at-home.com/hotspot-wifi-access-point/ and the SSID was visible…
thanks

The thing is that you need to set the proper drive in hostapd.conf

Yours is driver=rtl871xdrv, but we cannot change it dynamically… You can manually edit /etc/hostapd/hostapd.conf and /etc/hostapd/hostapd-edimax.conf

by adding\editing :
driver=rtl871xdrv
device_name=RTL8192CU

…I also read that there is a specific driver for TL-WN725N V2 raspberrypi.org/forums/view … 28&t=62371
I’ll try

thanks!

I confirm that using Edimax wifi usb adapter, as suggested, the hotspot work correctly, no configuration needed!
thanks

Another question on how to connect a Raspi Zero w/ Volumio 2 and Edimax USB Wifi:

As per guide from here: volumio.github.io/docs/User_Man … Guide.html
when I connect to 192.168.211.1/ with FiFo on my Mac, the browser says connection not possible (or such like).

The wifi connection seems to work, but after entering the hotspot password (which it accepts and connects to UUID:Volumio), it complains about not having internet, which obviously I don’t need:

ping on the terminal also confirms there’s no connection to the Pi.

On my Android phone, it says Volumio WiFi is connected, but the browser returns this:

Any hint what I can do to connect to the Volumio settings?

re the above: I kind of answered my own question. I’ve build up two more identical setups
Pi Zero + 8GB sdcard with Volumio 2.041 + WiFi USB Edimax EW-7811UN

Both work as expected, so need to swap components from setup 1) to find the cause.

By the way, very nice feature the hotspot. In Volumio1, if’ve needed to change the configs manually for the headless Pi.

Hey there,

is the suggested dongle compatible with Odroid c1+/c0?

or should I use a different one?

Cheers

Should work, as it is based on a Realtek RTL8188cu.
Hardkernel added the driver to the kernel sometime in 2015.
I included the driver for Volumio 2, so covered by the current kernel in the Odroid C0/C1/C1+ image.

-Gé-

thanks a lot!
one more question my current stick which doesn’t work uses a RTL 8188… it’s this one

amazon.de/gp/aw/d/B006Q3500 … 4766202640

should my dongle work? otherwise I will order the recommended one.

Cheers

Hi,
strange, seems to be the same chipset.
Can you ssh into volumio and do lsusb -t lsmod
and when you see something like 'rtl8188…" or anything from lsmod output, do a

modinfo rtl8188... using the exact module name that lsmod showed?
Perhaps that helps us a little further…

-Gé-

thanks will try to do this, tomorrow.
hope I get this done

Cheers

OK got to ssh with putty and tried the commands, but I cant do a modinfo
I attached the pic I get after first command.
I see its 8188eu and seems not in use…
Any ideas? I think I read something about activating the right driver…

Cheers

BTW I ordered the recommended stick and hope it will just work out :slight_smile: but would still be interested in solving this
P_20170119_191810.jpg

sorry, forget the permissions, do

sudo modinfo 8188eu

ah OK… here is what I got
P_20170119_204359.jpg
P_20170119_204122.jpg

Hey there

the recommended wlan stick did the trick :smiley:
now I need an equalizer, but it’s probably better to wait for the plug in.

BTW should I delete the pics?

Cheers

Ahhh theres one more question I got concerning the hotspot.
Is there any possibility to keep connection to the Internet with the smartphone, that is connected to the hotspot? Maybe an app that allows the phone to be connected to mobile data network and the hotspot?
Anything else like hardware implementation would probably be to complicated.

Cheers

I think that once your phone connects to the hotspot, it will not use 4G etc.

yeah I think there is no way to solve this via software.

Thanks anyway,
Cheers