Volumio GUI output to TV attached to PI3's HDMI

What pluggin or config is needed to output the UI to the display attached to
the PI3’s HDMI. Right now, it only shows the Rapsbian login prompt.

Go to the Plugin menu and install the touch screen plugin from “Miscellanea”.
It will work, but you may have to make these changes to disable typical touch screen issues (mouse pointer, scree timeout etc.)

Edited:

unclutter is for removing the cursor

sudo apt-get install unclutter

then edit /opt/volumiokiosk.sh

Change line #1, replace "+dpms" by "-dpms"
Change line #2, replace "blank" by "off"
Remove line #3

then add the following line to the end of /etc/xdg/openbox/autostart

@unclutter -idle 0

Tested with a 1080p monitor (TV) connected to a RPI3 and a Pine64 and with an Odroid VU7 (similar to waveio) connected to an Odroid C2.

1 Like

Does Pi version make a difference? I’d like to set this up to, but running on Pi 2

Remember to run sudo dpkg --configure -a to restart the install package configuration process of dpkg. You can then configure the pack in the interface.
Run again the installation routine of the touchscreen plugin that should now finish correctly.

I can’t install this plugin :frowning: There is some info that I need to choose keyboard but how?
Screenshot from 2019-05-20 21-36-49.png
Screenshot from 2019-05-20 21-37-09.png

Some old bug: touch-display-plugin-installation-hangs-t5677.html

Thank you, worked at a glance with RPi4 - Volumio 2 and touch display plugin + unclutter.
Thank you in advance.

BTW: With the current touch display plugin it is not necessary to edit /opt/volumiokiosk.sh in order to turn off the screensaver.

To disable the screensaver you just have to set the “Screensaver timeout” on the configuration page of the plugin to 0.

Also you don’t need to install unclutter and edit /etc/xdg/openbox/autostart if you just want to remove (i.e. don’t need fading in/out) the cursor.

The plugin has a switch on its configuration page called “Show mouse pointer” that lets you either hide (which is the default setting) or show the cursor. Using unclutter might interfere with the plugin’s switch to control the visibility of the cursor (I did not check).