Volumio freezing after a fresh install


I had to do a fresh installation the whole Volumio (unfortunately as it turned out at the end unnecessarily - was not able to play podcasts over volspotconnect which seems to be a known bug anyway) and since that I’m experiencing multiple freezes of Volumio per day. My old old build was already at least a year old, just updated through OTA.

In most of the cases the following behaviors occur:

  • during a playback of a radio station, volumio freezes playing the same sound over and over again
  • after a couple of hours of inactivity I’m not able to reach it neither through SSH nor a web interface - basically every morning I’m unable to use it

in both cases I have to manually disconnect a device from a power source to force a reboot.

Obviously using the latest version 2.729 installed on RPi 3B and pHAT DAC. Already tried a brand new micro sd card with the same result.

Is there anything that I can do, check or enable to provide you some logs that might help? :slight_smile:


Which plugins are you using?

Just added volspotconnect2, nothing else. Currently I see it’s 0.9.9 however I’m pretty sure that I saw it being updated to 1.0.x already.

Which power supply are you using?
Are you able to send a log (paste link here) after it freezes?

It’s 3A tablet charger that I’ve been using for around 2 years now.
Here’s the link to logs (last freeze was about 30-40 minutes ago, so around 13:00) I think:

The only modification I made is a cron session to run a script (/home/volumio/checkwifi.sh) that checks if wifi is on and restarts the module if needed - I thought that might be the reason of freezing when inactive. That’s something I’ve added after started experiencing this issue as a possible workaround.

I’ll post more after the next freeze

I don’t see anything that might suggest why it freezes.
Can you please send the log immediately after it freezes next time? thanks

You mean after a reboot (I won’t be able to access /dev page when it freezes)? Will logs contain previous session?

No, it must happen without rebooting… Otherwise we loose logs

Once it freezes, it freezes totally :slight_smile: I can’t access it in any way that I am aware of… Neither SSH or web interface works.

The only thing that comes to my mind now is to take sd card out of Pi and use card reader on another device - will that work? is a log located in /var/log/volumio.log sufficient?

Are you on wifi or ethernet? Which model do you have?

RPi 3 connected via wifi only

I managed to use the volumio sd card on a different linux system but I can’t find /var/log folder there…

I’ve got three partitions there with the following folder structure:

- boot 
- volumio
- volumio_data
  - dyn
    - data
    - etc
    - var
      - cache
      - lib
      - spool
      - tmp
  - lost+found
  - union
  - work