Volumio forgets WiFi settings on Raspberry Pi2

Volumio connects to WiFi just fine, but when I reboot it forgets my WiFi settings and can’t connect. My WiFi dongle (Edimax) is on the compatibility list. I don’t have this problem with RuneAudio or Raspbian.

Detailed steps:

  1. Connect Raspberry Pi2 to ethernet and WiFi dongle and boot Volumio.
  2. Volumio Web UI opens just fine (over ethernet at this point, even though Volumio network settings don’t show ethernet active).
  3. Type in WiFi network name and password in Volumio network settings. “Save changes” This greys out the Web UI and brings up the “Connecting” spinner. The screen is stuck in this state, so I close the tab and connect to the Web UI again.
  4. The Web UI opens and Volumio Network Settings now show that both ethernet and WiFi are active.
  5. Unplug ethernet cable. Web UI is working fully, so now I’m using only WiFi to connect. Fine.
  6. “Restart” Volumio.
  7. Can no longer connect. Volumio doesn’t remember the WiFi settings. Same thing happens if I power off Volumio and then reboot the Raspberry Pi.
  8. The above is very repeatable. I can get WiFi working again by plugging in the ethernet cable to get to the Web UI and then unplugging ethernet, but I need to move the Raspberry Pi to another room where there is not ethernet cable. Volumio needs to remember the WiFi settings.

Any help would be appreciated. The Network Settings seem very glitchy, but maybe there’s a workaround.

Is there a way edit a settings file by hand and force Volumio to connect to a specific WiFi network on startup?

It seems like a trivial issue. Anyone?

Even if the problem is not same, the solution for you could be here : https://volumio.org/forum/unable-add-modify-remove-mounts-using-webui-t2831-10.html
of course you have to change parameters for wifi…

I think I solved the problem. After entering the WiFi settings and clicking “Apply” the “Connecting” spinner seems to be stuck. However, I walked away at that point, and it wasn’t hung up–it just took forever to re-connect.

When the Web UI popped up again I saw for the first time the notice that “NetConfig” was updated. Unlike my previous interactions, my WiFi settings are now saved!

Lesson learned: this OS is slow and you need to give it ample time to do what it’s doing. Maybe Volumio 2 will be speedier, but at least it’s working now.