Volumio for PI 1.2 Feeback thread

Had problem with wireless on 1.2, went back to 1.1 and still had a problem with wireless. same issue on both 1.2 and again on 1.1. 1.1 was not a problem before.

By chance, before leaving for work, I decided to reboot the wireless router/switch/modem. (rebooted based on reading here that someone upgraded their router image. Trying minimal action first.)
Started the RPi and it now has an IP address.

I’m wondering now if it would have worked with 1.2 by restarting the wireless router? Maybe something needed to be cleared from a table in the wireless router?



I installed 1.2 a Week ago. With my Belkin USB N WLAN dongle i encountered the same WLAN problems: WLAN adapter only got an iip-address assigned if lan-cable was connected too. I narrowed it down to a dhcp problem (no lease available). Whether it was a problem with my network setup or the pi I can not tell. ( the belkin dongle worked with 1.1).

After reading this thread I decided to give the edimax wlan adapter a try. Successfully, Wlan works without problems now.

I use a pro-ject DAC box s, and had a lot of crackling while playing flac or high bit rate mp3s with 1.1.
With 1.2 there is nearly no crackling at all. The few cracklings could be related to parallel library update, which takes quite a long time for the nas (>24 hours).

So thank you very much, it seems this release is making my nas-hifi connection perfect!
Big Thumbs-up for the volumio project!


Hi Vince! Concerning wlan problems: You don’t need the wicd-curses- I used it in the beginning of my volumio experience, but it is not necessary to install them. Just try Edimax EW-7811 Un dongle- it’s cheap and works, let’s say at 90 % :wink: . You only need to do the setup in ‘networks’ on volumio webUI. At start with ethernet cable plugged, enter the SSID of your router, choose WPA/PSK security for password (I think your rooter is saved this way)- enter password- press ‘save changes’ and wait. Then Web UI writes something like ‘No IP obtained’- then reboot and you should have an IP adress for wireless.

I would recommend to set IP adresses in your router to static afterwards- so I did. Then there is no messing around with IP’s when more components have access to the router.

When playing music and you leave volumio web UI it happens, that reconnection is hard to make (you have to call up web UI several times in worst case).
You can avoid this when you don’t disconnect from volumio while listening to music.

Another possibility is to get direct connection between smartphone or tablet and raspberry pi. Therefore you only need to make the same setup in volumio as you make it with wlan in ‘networks’. But in this case you type the name of your phone as SSID that you have chosen and the password you created under WPA/PSK. For this you have to set up your phone as a hot spot and to activate WIFI- not wlan, so it works similar to your router.
This connection works without problems as I experienced- you only lose web radio of course when you have no ethernet cable plugged.

Don’t fall back to 1.1- I think that 1.2 sounds a bit better :wink:


Thanks for suggestion - however it did not help.

By the way, the update sequence should be:

sudo apt-get update sudo apt-get install binutils sudo apt-get install rpi-update sudo rpi-update

Thanks for the suggestions guys.

I’m going to get it running under 1.1 until I can get a Edimax wlan dongle.
Just got the HiFiberry DAC, so I’m trying to get anything going just to hear it.



Big Problem: I cannot find Volumio at the usual address in my net. No problem with 1.1

I think we need to remember to clear the browser cache from time to time when making changes. Couldn’t find the DSD USB DAC until I cleared the browser cache.

Usual address is a relative term with dhcp client enable. If you want the RPi to be at the same ip address, you’ll have to find your WLAN or NIC MAC address and force it in the router/modem/wireless appliance to be remembered.

If you can’t get an ip in Ver 1.2 join the club. Might want to try a edimax.
Some gave better luck with it as the WLAN adaptor.


Running 1.2 with a HiFiMe DAC and a 2.5 external USB on an USB hub, everything worked out of the box. No WiFi, I use the LAN interface.

Three problems I see:

PHP error messages keep filling up my log files.

Random Crashes, need to reboot. Don’t know exactly how to troubleshoot those.

Starting as of today I’m losing the IP on my Raspberry, have to disconnect and reconnect the LAN cable, wait for about 5 seconds, works fine afterwards. Router and/or cable are not the problem, all my other devices work perfectly fine.

I was able to ‘manually’ add my samba share via adding the ‘cifs utils’, and used mpd to play manually. However, the GUI refuses to add my shares. Additionally, the GUI keeps ‘crapping out’ and won’t save config stuff. If I edit via cli everything is fine. I am using wifi (I did have to manually add ‘never enable power saving mode’. I also configured my network manually and DON’t use wicd, but built in config. Music is rock solid for airplay, my main use, but the GUI seems to be mostly useless in that it hangs continually. No idea why, but just get ‘busy’ when doing almost anything that changes config. I am using a hifiberry dac, FYI.

My network config:
iface lo inet loopback

auto wlan0
iface wlan0 inet dhcp
wpa-ssid Munnster
wpa-psk MySuperSecretPassword

My modules.conf (local file) includes fix for crappy wireless problems:

options 8192cu rtw_power_mgnt=0 rtw_enusbss=0

Other than this I am running ‘stock’. Main ‘bug report’ is gui quitting and not coming back up until reboot.

Quick question about HiFi Berry DAC modules and version 1.2

When re-imaging to version Volumio 1.2, will the HiFi Berry modules be in the Modules file or will the Modules file need to be re-edited?



I had to manually edit /etc/localtime to get the right timezone in order to troubleshoot my wifi issues with REALTEK chipsets, my clock was set ahead by half a day (GMT). It would be nice to have this accessible in the settings.

I’ve upgraded from 1.1 beta to 1.2 beta today.
I only have positive comments.

My configuration consists of a Pi wired to a gigabyte switch and from there to a IOMEGA StoreCenter NAS; music data goes out via USB to a Musical Fidelity V-DAC I (the old, black, model, with adaptive - non-async - USB 16/44 input).
MPD configuration is using Hardware mixer.

I’m purposefully playing some classical music - currently a 16/44 FLAC’s version of La Boheme by Von Karajan.
The main difference to my hears is a quite lower frequency of pops (I haven’t been hearing one for minutes).

Another aspect I like very much (a minor one, but a big UI improvement) is that the back link while browsing the music collection does not go anymore back to the top of the previous page: it remembers the previous position in the collection.

newbie here. Let me say first thanks for all the great work. I’ve been using Volumio 1.2 on my Pi (model b) for a week now and I’m really impressed. I’ve tried other solutions (eg: pimusicbox) and non compare to volumio in quality and easy of use. I’m enjoying my music more now. I’m using my iphone with the webapp full-screen or Mpod and both are great solutions to control the music. I have the pi connected with HDMI to my receiver and that connected to my Infinity tower speakers, hopefully in the future I will upgrade to a standalone DAC to get better quality but I can say I’m content for now. I use only ripped CDs to FLAC that reside on a linux server and shared thru Samba. Pi is connected thru ethernet.

I’ve encounter only one significant problems (sorry if it has been mentioned before here) but when playing HiRes files 24/96 or 24/192 from hdtracks there is significant popping making the music unplayable. Again this is thru hdmi to my receiver (I was able to play them fine with the Pi and OpenELEC installed).

Thanks again and donation will be coming soon.

Seems to be working nicely out to a Musical Fidelity V-Link192/V-DACII. The only issue I’ve still got is that it’s still missing the first track on subdirectories of FL:ACs. Wherever I look, I’m a track short… Otherwise, good stuff and keep going!

Chris M

Forgot to say, Airplay is working just fine as well…

Hi All

The setup

Using Volumio for PI 1.2. with HIFIBerry via Home LAN network. Music via NAS DLINK Share centre 320L
Initial install setup worked well via Win32 Disk Imager.
Able to login to GUI but was unable to configure NAS drive.
Followed instruction in other forum “How to setup Windows Shared Drive”. via ssh.
Log’d in as root & pw volumio.
After reboot was able to configure DLINK 320L NAS and access NAS music files.
Set up play list- but was unable to play. :confused:
After some forum research found I needed to active I2C in setting.
This got it up and running with sound via amp to speakers. :smiley:

The review:

Played mostly MP3 ripped files to date. Can confirm that audio quality is superior to direct from Rotel CD player, PC via optical to Yamaha AMP, Borrowed HK Bluetooth adapter, and certainly Pi 3.5 mm to phono on amp.

Over the Lan there did not appear to be any latency or stuttering on tracks with standard default setting. No noise in quiet sections. No pops or mains hum.
Depth of field, position and focus all well reproduced. Plenty of bass detail. Yet to configure over wi fi. :smiley:

Next steps:

Attempted to access via S3 via sound@home app. but was unable to setup as screen sizes did not align. result was set up crashed and was unable to access via ssh as well. :confused:
Have now reinstalled new image but this time created a image copy of SD using Win32 Disk Imager to speed up re installs.
Also seemed to have a GUI crash but this seemed to be fixed via ssh service mpd restart.


Whilst the instillation was some what time consuming , once had understood the key steps the output quality was worth the wait. Needed some Pi basics as well.

I will continue to use volumio/Hifiberry as a main source to play music from the NAS. :smiley:

Would be nice to delete the whole play list not track by track. The GUI provide feedback on deletions but soon fills up if may files are deleted.

Please let me know if I can help assist -

Hope this feed back helps

After updating to 1.2 I can’t connect to my Pi. I’ve seen lot of problems with wifi, but for me it’s also over LAN. The Pi is getting a static ip, and I can see it on the network, but when I try to ping it I get a ‘host unreachable’. It won’t connect over ssh either, -network connection times out.
I’ve tried reformatting the SD card several times and re-downloaded the image, both direct and from the torrent, but nothing seems to help. There’s activity on the ACT led and the other leds also indacates that all should be OK.
I had contact for a few seconds right after one of the re-installs, but lost it again as I tried to browse the media library.

Really confused here. Any ideas?

EDIT: Now I don’t even see it on the network anymore…maybe it was just cached in my router or something…

SECOND EDIT: Re installed v1.1 and everything works fine immediately. Must be something more than just wifi issues with networking in 1.2.

96/24 FLAC files are much moore smooth now, no noticeable pops and clicks anymore here.

One issue that I have is: I have the PI connected via ethernet and I’m managing my music collection just by using windows explorer (directly pointing it to the IP adress).
It takes AGES to delete files. Once I can transfer them I will tell you if that’s also a problem, but right now, it says 1 hour remaining… for deletion of roughly 1.6GB of music.

Edit: Ok, after deleting half of the files, it crashed…


I have upgraded from 1.1 to 1.2
Here are my problems on 1.2 :

  • cannot connect to volumio.local ; I have to enter th IP adress on my navigator
  • hires FLAC 24/96 or 32/192 have many plop. Sometime the tempo goes slowly
    I prefer downdrading to 1.1

My setup :

  • RPI rev2
  • XMOS USB reciever
  • DAC Sabre ES9023 plugged on I2S to XMOS
  • Ethernet link or wifi but wifi cannot really goes fast enought to play hires files


Raspberry B with WaveIO usb to spdif and Buffalo II dac.

Totally unstable.

'till it works, everything ok, but after a little while, the system is on but mpd is not (I think). No sound, restarting mpd using the webgui does not make it work again. You have to reboot.

Used it mainly for webradios. But the same for airplay too…

All the best


Hi all!

For everyone who has problems with WIFI- connection and uses EDIMAX EW7811Un- dongle:

The problem with loosing connection is SOLVED for me!

I followed a hint of a forum member. Edimax dongle has a power management included and this prevents building up connection after a while 'cause the device falls into a kind of sleeping mode. But it is possible to deactivate this function. Afterwards WIFI works perfect!


Start putty (or use other ways) and connect to pi via SSH. Log in: ‘root’ password: ‘volumio’

Then type: sudo nano /etc/modprobe.d/8192cu.conf
then press return

There you add the lines:

Disable power management

options 8192cu rtw_power_mgnt=0 rtw_enusbss=0

Press Strg+ O then return then Strg+ X and type: sudo reboot
then press return

One more thing: It is better to give Volumio through WIFI a static IP address- that guarantees, that routers don’t mess up with a lot of IP addresses of changing devices.

Therefore first make the WIFI configuration in Volumio with correct SSID and WPA Key. Then press ‘save changes’
Wait till volumio shows something like’ No IP address assigned’ or ‘no Interface present’
Afterwards again connect through SSH- same procedure as described above.

Type: sudo nano /etc/network/interfaces
then press return

Search the line: iface wlan0 inet dhcp and change dhcp to static so it looks like:

iface wlan0 inet static

Then below add the lines:

address There you type your wished IP address (same as the router- only the last digits differ)
gateway IP of your router

In my configuration it looks like:

Below that you should see the allready registered SSID of your router and the WPA Key- Nothing to change here.

Press Strg+O then press return
Press Strg+ X and then type sudo reboot
then press return

After I’ve done all this WIFI with EDIMAX works absolutely perfect- faster and without connection losses!

Greetingz, Robert